Bug 325795 - Dolphin opens an unlimited number of windows if used to open archives
Summary: Dolphin opens an unlimited number of windows if used to open archives
Status: RESOLVED DUPLICATE of bug 318683
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.11.1
Platform: OpenSUSE Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-08 22:58 UTC by Erik Hahn
Modified: 2013-10-08 23:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Hahn 2013-10-08 22:58:05 UTC
When an archive file is passed to Dolphin via the command line, it doesn't try to show it using the appropriate KIO slave. Instead it opens the configured external application to do that.

This is a major problem if said application is Dolphin itself. In that case the newly opened instance of Dolphin will try to open the archive in yet another Dolphin, etc. 

Reproducible: Always

Steps to Reproduce:
1. Open a ZIP archive with "dolphin foo.zip"
Actual Results:  
Dolphin opens the archive in the configured external program, even if "Open archives as folder" is enabled and said external program is Dolphin itself.

Expected Results:  
If "Open archives as folder" is checked in Dolphin's config, it should do this. Otherwise it should open the archive in the configured external program if that is not Dolphin. If it is, Dolphin should do something more sensible than causing an infinite loop anyway.

I only tested this with ZIP files.
Comment 1 Christoph Feck 2013-10-08 23:10:48 UTC

*** This bug has been marked as a duplicate of bug 318683 ***