Bug 325694 - Network manager crash when introducing WPA key, soon after kde start
Summary: Network manager crash when introducing WPA key, soon after kde start
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: 0.9
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-10-06 09:35 UTC by vincenzocosta16
Modified: 2013-12-15 14:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vincenzocosta16 2013-10-06 09:35:10 UTC
Application: kded4 (4.11.2)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-11-generic x86_64
Distribution: Ubuntu Saucy Salamander (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
Soon after the boot of my laptop, the network manager asked for the WPA key for my home wi-fi network. At the first attempt the network applet did not show a succesfull connection and the window to insert the WPA key appeared again. At the second attempt there was a crash, but the network connection was succesfull soon after that.

- Unusual behavior I noticed:
The request for the WPA key is strange, since the network was already registered.
Clicking on the network icon showed two identical entries for the same home network.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Demone KDE (kded4), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff71f3327c0 (LWP 1735))]

Thread 6 (Thread 0x7ff704503700 (LWP 1737)):
#0  0x00007ff71cb9a47d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ff719ca7694 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff719ca779c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff71dfd1a76 in QEventDispatcherGlib::processEvents (this=0x7ff6fc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007ff71dfa35ef in QEventLoop::processEvents (this=this@entry=0x7ff704502db0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff71dfa38e5 in QEventLoop::exec (this=this@entry=0x7ff704502db0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff71dea288f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007ff71dea4f2f in QThreadPrivate::start (arg=0x1efad70) at thread/qthread_unix.cpp:338
#8  0x00007ff71a382f6e in start_thread (arg=0x7ff704503700) at pthread_create.c:311
#9  0x00007ff71cba6ecd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7ff6fb51c700 (LWP 1744)):
#0  0x00007ff71a385055 in __GI___pthread_mutex_lock (mutex=0x7ff6f4000a60) at pthread_mutex_lock.c:95
#1  0x00007ff719ce7391 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff719ca6d49 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff719ca75b3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ff719ca779c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ff71dfd1a76 in QEventDispatcherGlib::processEvents (this=0x7ff6f40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007ff71dfa35ef in QEventLoop::processEvents (this=this@entry=0x7ff6fb51bd70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007ff71dfa38e5 in QEventLoop::exec (this=this@entry=0x7ff6fb51bd70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007ff71dea288f in QThread::exec (this=this@entry=0x1eb04e0) at thread/qthread.cpp:542
#9  0x00007ff71df84d13 in QInotifyFileSystemWatcherEngine::run (this=0x1eb04e0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007ff71dea4f2f in QThreadPrivate::start (arg=0x1eb04e0) at thread/qthread_unix.cpp:338
#11 0x00007ff71a382f6e in start_thread (arg=0x7ff6fb51c700) at pthread_create.c:311
#12 0x00007ff71cba6ecd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7ff6e15c1700 (LWP 1779)):
#0  0x00007ff719ca6e1b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff719ca75b3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff719ca779c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff71dfd1a76 in QEventDispatcherGlib::processEvents (this=0x7ff6d40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007ff71dfa35ef in QEventLoop::processEvents (this=this@entry=0x7ff6e15c0d70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff71dfa38e5 in QEventLoop::exec (this=this@entry=0x7ff6e15c0d70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff71dea288f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007ff701aedfd7 in KCupsConnection::run() () from /usr/lib/libkcupslib.so
#8  0x00007ff71dea4f2f in QThreadPrivate::start (arg=0x1ef6b60) at thread/qthread_unix.cpp:338
#9  0x00007ff71a382f6e in start_thread (arg=0x7ff6e15c1700) at pthread_create.c:311
#10 0x00007ff71cba6ecd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7ff6e0dc0700 (LWP 1780)):
#0  0x00007ff71cb9a47d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ff719ca7694 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff719ca779c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff71dfd1a76 in QEventDispatcherGlib::processEvents (this=0x7ff6d80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007ff71dfa35ef in QEventLoop::processEvents (this=this@entry=0x7ff6e0dbfdb0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff71dfa38e5 in QEventLoop::exec (this=this@entry=0x7ff6e0dbfdb0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007ff71dea288f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007ff71dea4f2f in QThreadPrivate::start (arg=0x1eea220) at thread/qthread_unix.cpp:338
#8  0x00007ff71a382f6e in start_thread (arg=0x7ff6e0dc0700) at pthread_create.c:311
#9  0x00007ff71cba6ecd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7ff6d3db5700 (LWP 1788)):
#0  0x00007ff719ca4b8d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ff719ca6cdb in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff719ca75b3 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff719ca779c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ff71dfd1a76 in QEventDispatcherGlib::processEvents (this=0x7ff6cc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007ff71dfa35ef in QEventLoop::processEvents (this=this@entry=0x7ff6d3db4d70, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ff71dfa38e5 in QEventLoop::exec (this=this@entry=0x7ff6d3db4d70, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007ff71dea288f in QThread::exec (this=this@entry=0x2206670) at thread/qthread.cpp:542
#8  0x00007ff71df84d13 in QInotifyFileSystemWatcherEngine::run (this=0x2206670) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007ff71dea4f2f in QThreadPrivate::start (arg=0x2206670) at thread/qthread_unix.cpp:338
#10 0x00007ff71a382f6e in start_thread (arg=0x7ff6d3db5700) at pthread_create.c:311
#11 0x00007ff71cba6ecd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7ff71f3327c0 (LWP 1735)):
[KCrash Handler]
#5  0x00007ff6e35cb4be in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#6  0x00007ff6e35ba7dc in ConnectionList::addConnection(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#7  0x00007ff6e3376c9b in NMDBusSettingsConnectionProvider::initialiseAndRegisterRemoteConnection(QString const&) () from /usr/lib/libknm_nm.so
#8  0x00007ff6e33765d8 in NMDBusSettingsConnectionProvider::initConnections() () from /usr/lib/libknm_nm.so
#9  0x00007ff6e33773d3 in NMDBusSettingsConnectionProvider::serviceOwnerChanged(QString const&, QString const&, QString const&) () from /usr/lib/libknm_nm.so
#10 0x00007ff6e334917f in ?? () from /usr/lib/libknm_nm.so
#11 0x00007ff71dfb8a58 in QMetaObject::activate (sender=0x1ef66f0, m=m@entry=0x7ff71b582840 <QDBusConnectionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7fff4fe7e790) at kernel/qobject.cpp:3539
#12 0x00007ff71b3667ff in QDBusConnectionInterface::serviceOwnerChanged (this=<optimized out>, _t1=..., _t2=..., _t3=...) at .moc/release-shared/moc_qdbusconnectioninterface.cpp:224
#13 0x00007ff71b366ca1 in QDBusConnectionInterface::qt_static_metacall (_o=0x25306c8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff4fe7e920) at .moc/release-shared/moc_qdbusconnectioninterface.cpp:114
#14 0x00007ff71dfb8a58 in QMetaObject::activate (sender=0x1ef66f0, m=m@entry=0x7ff71b582840 <QDBusConnectionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7fff4fe7e920) at kernel/qobject.cpp:3539
#15 0x00007ff71b3668cf in QDBusConnectionInterface::NameOwnerChanged (this=<optimized out>, _t1=..., _t2=..., _t3=...) at .moc/release-shared/moc_qdbusconnectioninterface.cpp:252
#16 0x00007ff71b366a81 in QDBusConnectionInterface::qt_static_metacall (_o=0x25306c8, _o@entry=0x1ef66f0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=0, _id@entry=6, _a=0x7fff4fe7eb80) at .moc/release-shared/moc_qdbusconnectioninterface.cpp:118
#17 0x00007ff71b367167 in QDBusConnectionInterface::qt_metacall (this=0x1ef66f0, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0x7fff4fe7eb80) at .moc/release-shared/moc_qdbusconnectioninterface.cpp:177
#18 0x00007ff71b32ce36 in QDBusConnectionPrivate::deliverCall (this=0x1ef7710, object=0x1ef66f0, msg=..., metaTypes=..., slotIdx=11) at qdbusintegrator.cpp:951
#19 0x00007ff71dfbcdce in QObject::event (this=0x1ef66f0, e=<optimized out>) at kernel/qobject.cpp:1194
#20 0x00007ff71d341dfc in QApplicationPrivate::notify_helper (this=this@entry=0x1d17700, receiver=receiver@entry=0x1ef66f0, e=e@entry=0x2454b90) at kernel/qapplication.cpp:4567
#21 0x00007ff71d348470 in QApplication::notify (this=0x7fff4fe7f360, receiver=0x1ef66f0, e=0x2454b90) at kernel/qapplication.cpp:4353
#22 0x00007ff71ed22a6a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#23 0x00007ff71dfa48bd in QCoreApplication::notifyInternal (this=0x7fff4fe7f360, receiver=receiver@entry=0x1ef66f0, event=event@entry=0x2454b90) at kernel/qcoreapplication.cpp:946
#24 0x00007ff71dfa7e1f in sendEvent (event=0x2454b90, receiver=0x1ef66f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1c81150) at kernel/qcoreapplication.cpp:1570
#26 0x00007ff71dfa82c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#27 0x00007ff71dfd2073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#28 postEventSourceDispatch (s=0x1d17b70) at kernel/qeventdispatcher_glib.cpp:279
#29 0x00007ff719ca73a6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007ff719ca76f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007ff719ca779c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007ff71dfd1a55 in QEventDispatcherGlib::processEvents (this=0x1c83670, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#33 0x00007ff71d3e39d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007ff71dfa35ef in QEventLoop::processEvents (this=this@entry=0x7fff4fe7f230, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007ff71dfa38e5 in QEventLoop::exec (this=this@entry=0x7fff4fe7f230, flags=...) at kernel/qeventloop.cpp:204
#36 0x00007ff71dfa8e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#37 0x00007ff709e3e95b in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kded4.so
#38 0x00000000004083f5 in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2013-10-06 12:57:54 UTC
Which Plasma NM version do you use? You can see the version string in Manage Connections -> Other.
Comment 2 vincenzocosta16 2013-10-14 09:41:00 UTC
In Manage Connections -> Other I found: "versione 0.9.0.8 (nm09 20130310)"
Comment 3 Lamarque V. Souza 2013-12-15 14:29:01 UTC

*** This bug has been marked as a duplicate of bug 210878 ***