Bug 325650 - reading direction Right to Left
Summary: reading direction Right to Left
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: 0.17.1
Platform: unspecified Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-05 07:24 UTC by Fahad Al-Saidi
Modified: 2016-07-25 23:39 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Adobe reader- reading direction options (50.02 KB, image/png)
2013-10-05 07:25 UTC, Fahad Al-Saidi
Details
Adobe reader- reading direction options (Right to Left) (117.36 KB, image/png)
2013-10-05 13:14 UTC, Fahad Al-Saidi
Details
Okular- the current reading direction (left to right) (151.00 KB, image/png)
2013-10-05 13:15 UTC, Fahad Al-Saidi
Details
PDF file with RTL page layout pre-defined (Test Case) (110.50 KB, application/pdf)
2014-02-27 10:49 UTC, Abdellah Chelli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fahad Al-Saidi 2013-10-05 07:24:38 UTC
One feature I liked in Adobe Reader is the control over reading direction from Left to Right or Right to Left. I hope it will implemented in Okular one day. Please see the attached image for more understanding. 

Reproducible: Always
Comment 1 Fahad Al-Saidi 2013-10-05 07:25:37 UTC
Created attachment 82673 [details]
Adobe reader- reading direction options
Comment 2 Christoph Feck 2013-10-05 10:52:25 UTC
What does this option change? Scrolling direction on key presses? Please clarify exactly how Okular should work with this option enabled.
Comment 3 Fahad Al-Saidi 2013-10-05 13:13:21 UTC
This option gives the control over the order of pages when the view mode is facing pages (Center First page). I have attached two screen-shots one from adobe reader after enabling Reading direction Right to Left and the other from okular the current behavior. I tried to number the page in red to see what is changes.

This feature is useful with RTL language and you want to read tow page in the same view or you want to preview you book before sending it to the printer.
Comment 4 Fahad Al-Saidi 2013-10-05 13:14:11 UTC
Created attachment 82675 [details]
Adobe reader- reading direction options (Right to Left)
Comment 5 Fahad Al-Saidi 2013-10-05 13:15:58 UTC
Created attachment 82676 [details]
Okular- the current reading direction (left to right)
Comment 6 Christoph Feck 2013-10-05 20:46:25 UTC
Thanks for the update, swapping the two facing pages makes sense in RTL reading mode.
Comment 7 Albert Astals Cid 2013-10-07 22:19:23 UTC
Is there any reason the first page is centered in one of the screenshots but not on the other?
Comment 8 Fahad Al-Saidi 2013-10-08 04:11:53 UTC
(In reply to comment #7)
> Is there any reason the first page is centered in one of the screenshots but
> not on the other?

Because the one who starts from left is adobe reader way. The other is the default okular way of reading.
Comment 9 Albert Astals Cid 2013-10-10 00:23:10 UTC
Silly me, one of them is Okular :D Sorry about the stupid question :D

Confirming the thing, this doesn't mean it's going to be worked on, just that it makes sense.
Comment 10 Abdellah Chelli 2014-02-27 10:49:23 UTC
Created attachment 85344 [details]
PDF file with RTL page layout pre-defined (Test Case)

To test, Default: Page layout from Document
(This attachment is test with Acroread9, for same option)

- Okular and qpdfview have similar bugs, thought it may be helpful to mention
here:

evince gnome_bug#724704
https://bugzilla.gnome.org/show_bug.cgi?id=724704

qpdfview lp_bug#1281870 (Already made some advance)
https://bugs.launchpad.net/qpdfview/+bug/1281870

(Ref:
https://askubuntu.com/questions/421083/how-to-open-a-pdf-view-2-pages-at-a-time-but-for-arabic-pdfs-where-left-page-i/)
Comment 11 Abdellah Chelli 2014-03-21 10:49:13 UTC
Poppler commit "Qt: Expose document-supplied text direction" (http://cgit.freedesktop.org/poppler/poppler/commit/?id=b346df59ef0775f5bd74a9f7379b5f430ccd7b79) , may be released with next Poppler 0.26 . Property to be used for "Direction from document" option.
Comment 12 Albert Astals Cid 2014-03-21 22:24:33 UTC
As always, patches welcome :)
Comment 13 Fahad Al-Saidi 2015-09-27 04:55:00 UTC
This patch adds RTL reading mode to okular in following view modes:
- facing pages.
- facing ( center first page).
- Overview.

As well as adds “Right to left reading direction “ option to okular's settings.

the patch: https://git.reviewboard.kde.org/r/125397/
Comment 14 Fahad Al-Saidi 2016-01-07 15:44:30 UTC
any update?
Comment 15 Fahad Al-Saidi 2016-07-02 20:23:06 UTC
the patch is updated.
Comment 16 Olivier Churlaud 2016-07-25 23:39:59 UTC
Git commit 04908dba2f93842a0008ef1ba8c966621c615f9e by Olivier CHURLAUD.
Committed on 25/07/2016 at 23:37.
Pushed by ochurlaud into branch 'master'.

Adding RTL reading mode feature to okular

Commited on behalf of Fahad Al-Saidi

REVIEW: 125397

M  +1    -0    conf/dlggeneral.cpp
M  +73   -13   conf/dlggeneralbase.ui
M  +3    -0    conf/okular.kcfg
M  +25   -6    ui/pageview.cpp

http://commits.kde.org/okular/04908dba2f93842a0008ef1ba8c966621c615f9e