Bug 325112 - Hang when opening folder of images to view thumbs
Summary: Hang when opening folder of images to view thumbs
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Thumbs-Image (show other bugs)
Version: 3.4.0
Platform: MacPorts Packages macOS
: NOR grave (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-20 06:11 UTC by peterl
Modified: 2017-07-15 16:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peterl 2013-09-20 06:11:40 UTC
I have been using older versions of digiKam successfully on my OS X 10.8.4 machine. I upgraded my MacPorts to the latest (digiKam 3.4.0_0, kde 4.11.1_0). Now when I launch digiKam, it starts up, but when I click on a folder in the navigation pane, no thumbs are displayed, and digiKam hangs. Beachball of death.

When I run digiKam from the command line, no errors are output at hang time.

I tried deleting the databases, but after re-adding the image folder it hung again.

Reproducible: Always

Steps to Reproduce:
1. Open digiKam.
2. Click on an Album in the left-hand navigation pane.
Actual Results:  
digiKam hangs. Need to force quit the app.

Expected Results:  
Thumbnails displayed.
Comment 1 caulier.gilles 2013-09-21 12:28:44 UTC
when port package is processed, you need to run manually these lines :

> launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist
> /opt/local/bin/kbuildsycoca

I use a macbook pro here, and digiKam work as expected...

Gilles Caulier
Comment 2 caulier.gilles 2013-10-31 08:03:09 UTC
digiKam 3.5.0 is out.

Can you give a fresh feedback about your report ? Problem still reproducible ?

Thanks in advance

Gilles Caulier
Comment 3 caulier.gilles 2013-11-25 12:13:37 UTC
Problem is not reproducible here under OSX / Maverick / macbookpro / KDE 4.11.5 / Qt4.8 / digiKam 3.5.0. I use a huge collection. There is no hangs out of application.

Gilles Caulier
Comment 4 Philip Tuckey 2014-01-30 23:21:12 UTC
I met a similar bug but was able to find more detailed information about how to provoke it and also a workaround for recovering from it. See Bug 330598.