Bug 325071 - Update friends action does not work in send private message window
Summary: Update friends action does not work in send private message window
Status: RESOLVED FIXED
Alias: None
Product: choqok
Classification: Applications
Component: Twitter (show other bugs)
Version: 1.4
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: 1.5
Assignee: Daniel Kreuter
URL:
Keywords:
: 328674 337890 342895 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-18 19:41 UTC by Vasileios P. Lourdas
Modified: 2015-01-27 11:27 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.5


Attachments
Clumsy patch (5.55 KB, patch)
2014-09-09 00:10 UTC, Ian Schwarz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vasileios P. Lourdas 2013-09-18 19:41:05 UTC
When I try to send a new private message and the window opens up, the To drop down list is empty. If I click the Reload friends list button, no entries are fetched. The status in the main application window displays "Friends list for account .... has been updated".

Reproducible: Always

Steps to Reproduce:
1. Click on send private message option 
2. Click on the Reload friends list button
Actual Results:  
It should have fetched the list of friends.

Expected Results:  
Nothing is fetched.
Comment 1 Mehrdad Momeny 2013-09-19 01:49:30 UTC
Daniel, Could you please check this!?
Comment 2 Daniel Kreuter 2013-09-19 16:13:40 UTC
Hi,

I've tried to reproduce the issue and can confirm it. I will have a look at it (I know in some ways where the problem is but I don't have a working solution yet.)
Comment 3 Vasileios P. Lourdas 2013-11-20 20:10:47 UTC
There's something else about updating the friends list, which might be related to this bug.

I have Choqok started. I go to twitter with my browser and follow a new guy. On the main Choqok window, I click on More->Update friends list, which does seem to do something (the status bar displays "The friends list for account xxx  has been updated"). I click inside the tweet text box, and type @Ma (the first few letters of the new guy that I just followed) and the popup does not display this guy's name. I even close Choqok and restart it, but even then, the list is not updated with the new guy's name.

Is there a roadmap for a newer version?
Comment 4 Daniel Kreuter 2013-11-20 20:27:30 UTC
Hi Vasileios,

thanks for providing your feedback.
I have worked on this bug a few weeks ago and I have a working patch send to the mailing list [1], with one thing missing (which isn't that bad when you follow less than 100 people)

Since I currently have no time for finishing it, you need to wait a bit longer or, if you have less than 100 friends on twitter and you need that feature now, you can apply my patch and compile choqok from source.

I'll start finishing it somewhere mid december.


[1]http://markmail.org/message/3it334umvq6ye54z
Comment 5 Miro.Collas 2013-12-08 08:25:35 UTC
I don't know if this is related or not. As of 2-3 weeks ago, I am unable to DM anyone with choqok, including people I have been following for a long time (years). If I reply to a DM, the small window opens, I type the message, then click "Send", and nothing happens. The message is not sent, the window does not close.

Possibly related: if I click on the name of the sender of a tweet - a person I am following - then "Actions", I always has the option "Follow", even though I already am. Therefore, I cannot Unfollow using choqok, since it appears to think I am not following in the first place.
Comment 6 Miro.Collas 2013-12-08 22:40:12 UTC
Blocking doesn't work either. Just tested: blocked someone with choqok, then checked the twitter website.
Comment 7 Daniel Kreuter 2014-01-17 17:50:45 UTC
*** Bug 328674 has been marked as a duplicate of this bug. ***
Comment 8 Mehrdad Momeny 2014-07-30 01:48:39 UTC
*** Bug 337890 has been marked as a duplicate of this bug. ***
Comment 9 Dan Duris 2014-07-30 16:27:25 UTC
Still not working. Is this Choqok incorrectly using Twitter API or is this a different bug not related to the Twitter API?

E.g. is it problem with API URL and such or unrelated to API URLs/commands.
Comment 10 Vasileios P. Lourdas 2014-07-30 16:37:25 UTC
I reported this bug several months ago. I haven't seen a Choqok release for some time now, has the development ceased?
Comment 11 Ian Schwarz 2014-09-09 00:10:16 UTC
Created attachment 88623 [details]
Clumsy patch

This is a patch that restores Direct Message, Follow/Unfollow and Block functionality.
I know bugger all about C++/Qt, so it's probably even clumsier a patch than I think, but it works (for me).

In other news:
Choqok development really seems to have ceased
No other Twitter client on Linux works. At all.
Comment 12 Ian Schwarz 2014-09-09 00:13:21 UTC
Oh yeah, the patch also changes Choqok's behavior slightly insofar as Timelines are updated when a Direct Message is sent, and the avatars in the Outbox are now yours instead of the recipients'.
Comment 13 Dan Duris 2014-09-09 07:38:48 UTC
Thanks, Ian. Any tips on compiling or possibility to make deb/rpm?
Comment 14 Mehrdad Momeny 2014-09-09 14:54:11 UTC
Git commit e45a7e7e872c8f808947c334b629e0d2ce1fd938 by Mehrdad Momeny.
Committed on 09/09/2014 at 14:52.
Pushed by momeny into branch 'master'.
Related: bug 100
And so following/unfollowing and blocking users

Thanks to twitter user: @_tnbp for the patch.

M  +28   -19   helperlibs/twitterapihelper/twitterapimicroblog.cpp

http://commits.kde.org/choqok/e45a7e7e872c8f808947c334b629e0d2ce1fd938
Comment 15 Mehrdad Momeny 2014-09-09 14:58:56 UTC
(In reply to Ian Schwarz from comment #11)
> Created attachment 88623 [details]
> Clumsy patch
> 
> This is a patch that restores Direct Message, Follow/Unfollow and Block
> functionality.
> I know bugger all about C++/Qt, so it's probably even clumsier a patch than
> I think, but it works (for me).
> 
> In other news:
> Choqok development really seems to have ceased
> No other Twitter client on Linux works. At all.

Thanks for the patch.
Comment 16 Andrea Scarpino 2015-01-27 11:27:04 UTC
*** Bug 342895 has been marked as a duplicate of this bug. ***