Bug 324991 - CSV Import Plugin - Improve handling of error condition
Summary: CSV Import Plugin - Improve handling of error condition
Status: RESOLVED DUPLICATE of bug 282763
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: git (master)
Platform: Mint (Ubuntu based) Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-17 10:43 UTC by allan
Modified: 2013-09-29 16:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description allan 2013-09-17 10:43:29 UTC
If the user attempts to import a file with incorrect rows selected, it is possible to be unable to correct the error without reloading the CSV file.

Reproducible: Sometimes

Steps to Reproduce:
1. Perform the usual steps to import a CSV file, until reaching the Lines page.
2. On that page, select an incorrect start (or end) line, such that a line with invalid format is included in the import selection, then click Next.
3. An error message is likely to appear indicating that an incorrect value has been detected on the invalid row.
4. Instead of clicking Cancel, click an Accept button.
5. On the Finish page, click Import CSV.
6. Another error message now is likely to appear, when the import data is parsed. Generally, the error first detected is likely to be an incorrect date value. Click OK.
7a. What the user should do next is to click on Back and correct the line number then click Next.
8a. Back on the Finish page, the only buttons available are Back or Cancel.
7b. Instead of Back, click Import CSV.
8b. The screen does not change.

Actual Results:  
As described.

Expected Results:  
It should be possible to correct the row settings.

This occurs for both banking and investing files.
Comment 1 allan 2013-09-21 09:46:04 UTC
This bug was discovered while investigating https://bugs.kde.org/show_bug.cgi?id=282763 .

The fixes for both bugs are intertwined, so just a single fix will fix both.  See https://bugs.kde.org/show_bug.cgi?id=282763
Comment 2 allan 2013-09-21 09:47:01 UTC

*** This bug has been marked as a duplicate of bug 282763 ***
Comment 3 allan 2013-09-29 16:26:26 UTC
Git commit 1a7483ef7d73cec1be91df1e2bf18fb4b91bdcf9 by Allan Anderson.
Committed on 19/09/2013 at 12:21.
Pushed by allananderson into branch 'master'.
Related: bug 282763

M  +18   -15   kmymoney/plugins/csvimport/csvdialog.cpp
M  +31   -3    kmymoney/plugins/csvimport/investprocessing.cpp

http://commits.kde.org/kmymoney/1a7483ef7d73cec1be91df1e2bf18fb4b91bdcf9