Bug 324972 - Import fails without an error when account is defined in CSV
Summary: Import fails without an error when account is defined in CSV
Status: RESOLVED FIXED
Alias: None
Product: skrooge
Classification: Unclassified
Component: general (show other bugs)
Version: 1.7.1
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Guillaume DE BURE
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-16 18:27 UTC by jmu
Modified: 2013-09-17 10:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jmu 2013-09-16 18:27:00 UTC
If the imported CSV file contains the account information (account exists in, the import fails without raising an issue. Once the account information is removed, the import works while the account is set based on file name.

Reproducible: Always

Steps to Reproduce:
1. Produce a CSV file

account;amount;date
My account;1000;08.08.2013

2. Import using import functionality
Actual Results:  
Entries are not imported.

Expected Results:  
Values should be imported and account info mapped to existing
Comment 1 jmu 2013-09-16 18:30:05 UTC
If the account does not yet exist in Skrooge, the file entries gets imported.
Comment 2 Stephane MANKOWSKI 2013-09-16 19:40:24 UTC
This is normal if the option "Import only operation since the last imported one" and this operation date 08.08.2013 is before the last already imported operation.

Could you check if you are in this case?
Comment 3 Stephane MANKOWSKI 2013-09-17 10:15:24 UTC
Git commit dfe4d61d7471688c39dac011e1f164f054a2b869 by Stephane Mankowski.
Committed on 17/09/2013 at 10:15.
Pushed by smankowski into branch 'master'.
Import fails without an error when account is defined in CSV
New warning in case of operation not imported because before the last imported one

M  +1    -0    CHANGELOG
M  +13   -3    skgbankmodeler/skgimportexportmanager.cpp
A  +2    -0    tests/input/skgtestvariousbugs/324972_1.csv
A  +2    -0    tests/input/skgtestvariousbugs/324972_2.csv
M  +37   -0    tests/skgbankmodelertest/skgtestvariousbugs.cpp

http://commits.kde.org/skrooge/dfe4d61d7471688c39dac011e1f164f054a2b869