Bug 324900 - Impossible to select collection subfolder in duplicates search
Summary: Impossible to select collection subfolder in duplicates search
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: Searches-Similarity (show other bugs)
Version: 3.4.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-13 22:54 UTC by nucleo
Modified: 2014-08-31 10:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nucleo 2013-09-13 22:54:28 UTC
In Digikam <= 3.3.0 it was possible to select collection subfolder in duplicates search.
In 3.4.0 this is impossible, only whole collection can be selected, subfolders not shown.

Reproducible: Always
Comment 1 nucleo 2013-09-14 12:12:20 UTC
I found that subfolders shown after I doubleclicked on collection folder but this is not obvious because nothing shows that folder can be expanded,
Also changed behavior of selecting folder because it not selects all its subfolders.
Comment 2 nucleo 2013-09-14 12:14:04 UTC
After doubleclicking on collection folder list stay too small for selecting subfolders.
Comment 3 nucleo 2013-09-24 11:06:08 UTC
Also I noticed problem with uncheck of subfolders.
If I uncheck folders saved from previous digiKam start and select other folder, then after search with this folder selection of previously selected folders back.
Comment 4 caulier.gilles 2014-08-31 08:46:46 UTC
Nucleo,

Problem still valid using last digiKam 4.2.0 ?

Gilles Caulier
Comment 5 caulier.gilles 2014-08-31 10:32:46 UTC
I just test with git/master implementation and sub-albums selection work fine here...

Gilles Caulier