Bug 324780 - Crash on startup
Summary: Crash on startup
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ColorManagement-Backend (show other bugs)
Version: 3.3.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-11 10:25 UTC by tomasz
Modified: 2022-02-01 11:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomasz 2013-09-11 10:25:23 UTC
Application: digikam (3.3.0)
KDE Platform Version: 4.11.1
Qt Version: 4.8.2
Operating System: Linux 3.2.0-53-generic x86_64
Distribution: Ubuntu 12.04.3 LTS

-- Information about the crash:
Freshly installed 3.3 (from https://launchpad.net/~kubuntu-ppa/+archive/backports) crashes on startup.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fdd3c782a00 (LWP 8725))]

Thread 5 (Thread 0x7fdd16e65700 (LWP 8726)):
#0  0x00007fdd3603e313 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fdd2e937036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdd2e93749a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdd16e6a98b in ?? () from /usr/lib/x86_64-linux-gnu/gio/modules/libdconfsettings.so
#4  0x00007fdd2e9589e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fdd3114fe9a in start_thread (arg=0x7fdd16e65700) at pthread_create.c:308
#6  0x00007fdd36049ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fdd16664700 (LWP 8727)):
#0  0x00007fdd3115305d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7fdd10010310) at pthread_mutex_unlock.c:290
#2  0x00007fdd2e9725d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdd2e9361f8 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fdd2e936f04 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fdd2e93749a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fdd21369406 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#7  0x00007fdd2e9589e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007fdd3114fe9a in start_thread (arg=0x7fdd16664700) at pthread_create.c:308
#9  0x00007fdd36049ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fdd04cc1700 (LWP 8729)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fdd36e205ab in wait (time=18446744073709551615, this=0xf55c20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xf55b28, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005e0860 in Digikam::ScanController::run (this=0xf558c0) at /build/buildd/digikam-3.3.0/core/digikam/database/scancontroller.cpp:725
#4  0x00007fdd36e2009b in QThreadPrivate::start (arg=0xf558c0) at thread/qthread_unix.cpp:307
#5  0x00007fdd3114fe9a in start_thread (arg=0x7fdd04cc1700) at pthread_create.c:308
#6  0x00007fdd36049ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fdcfffff700 (LWP 8730)):
#0  0x00007fdd3603e313 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fdd2e937036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdd2e937164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdd36f4e926 in QEventDispatcherGlib::processEvents (this=0x7fdcf80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fdd36f1de62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fdd36f1e0b7 in QEventLoop::exec (this=0x7fdcffffeb50, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fdd36e1d077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fdd36efdb6f in QInotifyFileSystemWatcherEngine::run (this=0xf583c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fdd36e2009b in QThreadPrivate::start (arg=0xf583c0) at thread/qthread_unix.cpp:307
#9  0x00007fdd3114fe9a in start_thread (arg=0x7fdcfffff700) at pthread_create.c:308
#10 0x00007fdd36049ccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fdd3c782a00 (LWP 8725)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fdd3137825e in cmsReadTag () from /usr/lib/x86_64-linux-gnu/liblcms2.so.2
#8  0x00007fdd39d685ea in dkCmsTakeProductDesc (hProfile=0x1298b10) at /build/buildd/digikam-3.3.0/core/libs/dklcms/digikam-lcms.cpp:376
#9  0x00007fdd39dda6e9 in Digikam::IccProfile::description (this=0x1264950) at /build/buildd/digikam-3.3.0/core/libs/dimg/filters/icc/iccprofile.cpp:389
#10 0x00007fdd39df66af in Digikam::IccSettings::loadAllProfilesProperties (this=0x116cfb0) at /build/buildd/digikam-3.3.0/core/libs/dimg/filters/icc/iccsettings.cpp:583
#11 0x00000000005a254d in Digikam::DigikamApp::DigikamApp (this=0x11995e0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /build/buildd/digikam-3.3.0/core/digikam/main/digikamapp.cpp:227
#12 0x00000000004916f4 in main (argc=1, argv=<optimized out>) at /build/buildd/digikam-3.3.0/core/digikam/main/main.cpp:189

Reported using DrKonqi
Comment 1 caulier.gilles 2013-09-11 10:48:35 UTC
It crash in liblcms2. You have probably a color profile uncompatible.

Report this problem to LCMS team

Gilles Caulier
Comment 2 caulier.gilles 2017-07-23 13:00:21 UTC
Since digiKam 5.0.0, we use drop lcms version 1.x in favor of lcms version 2.x. This problem will not reproducible.