Bug 324742 - kwin does not apply vsync on login
Summary: kwin does not apply vsync on login
Status: RESOLVED DUPLICATE of bug 322060
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: 4.11.1
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-10 11:49 UTC by Nikos Chantziaras
Modified: 2013-09-10 11:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Chantziaras 2013-09-10 11:49:38 UTC
kwin doesn't apply vsync when logging in. The vsync checkbox is enabled in System Settings and the setting is stored correctly in kwinrc:

GLPreferBufferSwap=a

The method used doesn't matter (automatic, only when cheap, etc.) In order to activate vsync after logging in, I have to open the desktop effects settings, and change any random setting (doesn't have to be the vsync checkbox, which is already checked) and then click "apply".

This problem did not occur with KDE 4.10.97. It started with 4.11.0 and also exists in 4.11.1. My ~/.kde4 directory was created by 4.10.97.

Reproducible: Always

Steps to Reproduce:
1. Enable VSync in the Desktop Effects settings.
2. Reboot.
3. Login into KDE
Actual Results:  
Tearing when moving windows.

Expected Results:  
Tear-free animations due to VSync being enabled in the Desktop Effects settings.

X.Org server 1.14.2
Qt 4.8.5
NVidia driver 325.15 on a GTX 560 Ti
Kernel 3.10.11
Comment 1 Thomas Lübking 2013-09-10 11:51:51 UTC
https://git.reviewboard.kde.org/r/112368/

*** This bug has been marked as a duplicate of bug 322060 ***