Bug 324706 - Title information of PDF v1.5 files displayed incorrectly
Summary: Title information of PDF v1.5 files displayed incorrectly
Status: RESOLVED DUPLICATE of bug 325008
Alias: None
Product: nepomuk
Classification: Unclassified
Component: widgets - FileMetadataWidget (show other bugs)
Version: 4.11.0
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Nepomuk Bugs Coordination
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-09 17:01 UTC by PeterF
Modified: 2013-10-12 19:47 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Incorrect title info (18.77 KB, image/jpeg)
2013-09-09 17:06 UTC, PeterF
Details
correct title info (17.03 KB, image/jpeg)
2013-09-09 17:06 UTC, PeterF
Details
problematic PDF file (352.58 KB, image/pdf)
2013-09-10 04:57 UTC, PeterF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description PeterF 2013-09-09 17:01:54 UTC
The title information for any PDF file v1.5 is displayed incorrectly in Dolphin.
The title information for PDF files v1.3, 1.4 or 1.6 are not affected and displayed correctly.

Reproducible: Always

Steps to Reproduce:
1. active right info panel
2. hover the mouse over any PDF file to display the metadata in the panel
3. PDF files v1.5 are displayed with a garbled title information


Expected Results:  
The title information should be displayed correctly.
Comment 1 PeterF 2013-09-09 17:05:04 UTC
The PDF files on my machine are a mixture of windows, macos and linux generated.
Comment 2 PeterF 2013-09-09 17:06:01 UTC
Created attachment 82241 [details]
Incorrect title info

PDF file v1.5 with garbled title information
Comment 3 PeterF 2013-09-09 17:06:37 UTC
Created attachment 82242 [details]
correct title info

PDF file v1.4 with correct title information
Comment 4 Frank Reininghaus 2013-09-09 19:01:32 UTC
Thanks for the bug report. The widget that displays this information is provided by Nepomuk.

It might help if you could attach a problematic file.
Comment 5 PeterF 2013-09-10 04:57:39 UTC
Created attachment 82250 [details]
problematic PDF file

PDF v1.5 where the title appears garbled in nepomuk (dolphin).
Comment 6 Simeon Bird 2013-09-11 00:00:21 UTC
This for me correctly displays "Inhalt der LV" as the title.

The title shown is the text in the largest box on the first page, extracted using poppler, because the real pdf title is "Powerpoint-Prasentation".  If it works correctly for you for other files with similar titles that just have a different pdf version, this looks like a poppler bug (nowhere in nepomuk do we know about the pdf version - poppler handles that).

I suggest you find a way to update poppler to a fixed version - I have 0.24.1, which seems to work.
Comment 7 PeterF 2013-09-11 19:35:27 UTC
(In reply to comment #6)
> This for me correctly displays "Inhalt der LV" as the title.
> 
> The title shown is the text in the largest box on the first page, extracted
> using poppler, because the real pdf title is "Powerpoint-Prasentation".  If
> it works correctly for you for other files with similar titles that just
> have a different pdf version, this looks like a poppler bug (nowhere in
> nepomuk do we know about the pdf version - poppler handles that).
> 
> I suggest you find a way to update poppler to a fixed version - I have
> 0.24.1, which seems to work.

Thanks for checking. Unfortunately previous Ubuntu versions never get an update to libpoppler (Kubuntu 12.10 is currently on 0.20.4), so I guess I will have to live with it or do a dist-upgrade.
Peter
Comment 8 Simeon Bird 2013-09-11 21:33:14 UTC
> Thanks for checking. Unfortunately previous Ubuntu versions never get an
> update to libpoppler (Kubuntu 12.10 is currently on 0.20.4), so I guess I
> will have to live with it or do a dist-upgrade.
> Peter

Sorry - probably easiest to live with the weird title in that case. 
Thanks for the bug report, anyway.
Comment 9 Vishesh Handa 2013-10-04 13:22:47 UTC
Changing to RESOLVED - UPSTREAM instead of UNMAINTAINED :)
Comment 10 Christoph Feck 2013-10-12 19:47:26 UTC

*** This bug has been marked as a duplicate of bug 325008 ***