Bug 324468 - folding crash
Summary: folding crash
Status: RESOLVED DUPLICATE of bug 311866
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: 3.10.5
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-03 16:46 UTC by Edgar GP.
Modified: 2013-09-03 20:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edgar GP. 2013-09-03 16:46:52 UTC
Application: kate (3.10.5)
KDE Platform Version: 4.10.5
Qt Version: 4.8.4
Operating System: Linux 3.8.0-29-generic x86_64
Distribution: Linux Mint 15 Olivia

-- Information about the crash:
Folding crash the suystem
CTRL+ALT+-
UP

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3de97237c0 (LWP 5088))]

Thread 3 (Thread 0x7f3dd4e3a700 (LWP 5089)):
#0  0x00007f3de6693075 in __GI___pthread_mutex_lock (mutex=0x7f3dd0000a60) at pthread_mutex_lock.c:95
#1  0x00007f3de61fd5c1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3de61be0d5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3de61be304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f3de6f8a036 in QEventDispatcherGlib::processEvents (this=0x7f3dd00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f3de6f5a38f in QEventLoop::processEvents (this=this@entry=0x7f3dd4e39d90, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f3de6f5a618 in QEventLoop::exec (this=this@entry=0x7f3dd4e39d90, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f3de6e5c410 in QThread::exec (this=this@entry=0x186ffc0) at thread/qthread.cpp:542
#8  0x00007f3de6f3bedf in QInotifyFileSystemWatcherEngine::run (this=0x186ffc0) at io/qfilesystemwatcher_inotify.cpp:256
#9  0x00007f3de6e5ebec in QThreadPrivate::start (arg=0x186ffc0) at thread/qthread_unix.cpp:338
#10 0x00007f3de6690f8e in start_thread (arg=0x7f3dd4e3a700) at pthread_create.c:311
#11 0x00007f3de9061e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f3dcffff700 (LWP 5090)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f3dd6c03e77 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f3dd6c03ea9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f3de6690f8e in start_thread (arg=0x7f3dcffff700) at pthread_create.c:311
#4  0x00007f3de9061e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f3de97237c0 (LWP 5088)):
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0) at ../../part/render/katelinelayout.cpp:173
#7  0x00007f3dd728e2e8 in KateLineLayout::viewLine (this=<optimized out>, viewLine=viewLine@entry=-1) at ../../part/render/katelinelayout.cpp:179
#8  0x00007f3dd728a9d6 in KateLayoutCache::textLayout (this=<optimized out>, realLine=<optimized out>, _viewLine=_viewLine@entry=-1) at ../../part/render/katelayoutcache.cpp:355
#9  0x00007f3dd72d780a in KateViewInternal::previousLayout (this=this@entry=0x1cc4b10) at ../../part/view/kateviewinternal.cpp:1261
#10 0x00007f3dd72e0783 in KateViewInternal::cursorUp (this=0x1cc4b10, sel=<optimized out>) at ../../part/view/kateviewinternal.cpp:1429
#11 0x00007f3de6f700ef in QMetaObject::activate (sender=sender@entry=0x1dc44d0, m=m@entry=0x7f3de8f287a0 <QAction::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffff39ebef0) at kernel/qobject.cpp:3539
#12 0x00007f3de8480152 in QAction::triggered (this=this@entry=0x1dc44d0, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#13 0x00007f3de8481580 in QAction::activate (this=0x1dc44d0, event=event@entry=QAction::Trigger) at kernel/qaction.cpp:1257
#14 0x00007f3de84816e7 in QAction::event (this=<optimized out>, e=e@entry=0x7ffff39ec490) at kernel/qaction.cpp:1183
#15 0x00007f3de76838a7 in KAction::event (this=<optimized out>, event=0x7ffff39ec490) at ../../kdeui/actions/kaction.cpp:131
#16 0x00007f3de84868ec in QApplicationPrivate::notify_helper (this=this@entry=0x17038d0, receiver=receiver@entry=0x1dc44d0, e=e@entry=0x7ffff39ec490) at kernel/qapplication.cpp:4567
#17 0x00007f3de848925b in QApplication::notify (this=this@entry=0x7ffff39edcc0, receiver=receiver@entry=0x1dc44d0, e=e@entry=0x7ffff39ec490) at kernel/qapplication.cpp:4428
#18 0x00007f3de775f1a6 in KApplication::notify (this=0x7ffff39edcc0, receiver=0x1dc44d0, event=0x7ffff39ec490) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007f3de6f5b63e in QCoreApplication::notifyInternal (this=0x7ffff39edcc0, receiver=0x1dc44d0, event=event@entry=0x7ffff39ec490) at kernel/qcoreapplication.cpp:946
#20 0x00007f3de84b9754 in sendEvent (event=0x7ffff39ec490, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QShortcutMap::dispatchEvent (this=this@entry=0x17039f0, e=e@entry=0x7ffff39eca60) at kernel/qshortcutmap.cpp:884
#22 0x00007f3de84b9bb3 in QShortcutMap::tryShortcutEvent (this=0x17039f0, o=o@entry=0x1cc4b10, e=e@entry=0x7ffff39eca60) at kernel/qshortcutmap.cpp:364
#23 0x00007f3de848add0 in QApplication::notify (this=this@entry=0x7ffff39edcc0, receiver=receiver@entry=0x1cc4b10, e=e@entry=0x7ffff39eca60) at kernel/qapplication.cpp:3991
#24 0x00007f3de775f1a6 in KApplication::notify (this=0x7ffff39edcc0, receiver=0x1cc4b10, event=0x7ffff39eca60) at ../../kdeui/kernel/kapplication.cpp:311
#25 0x00007f3de6f5b63e in QCoreApplication::notifyInternal (this=0x7ffff39edcc0, receiver=receiver@entry=0x1cc4b10, event=0x7ffff39eca60, event@entry=0x7ffff39ec910) at kernel/qcoreapplication.cpp:946
#26 0x00007f3de8485226 in sendSpontaneousEvent (event=event@entry=0x7ffff39ec910, receiver=receiver@entry=0x1cc4b10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#27 qt_sendSpontaneousEvent (receiver=receiver@entry=0x1cc4b10, event=event@entry=0x7ffff39eca60) at kernel/qapplication.cpp:5565
#28 0x00007f3de8529649 in QKeyMapper::sendKeyEvent (keyWidget=keyWidget@entry=0x1cc4b10, grab=grab@entry=false, type=QEvent::KeyPress, code=16777235, modifiers=..., text=..., autorepeat=autorepeat@entry=false, count=1, nativeScanCode=111, nativeVirtualKey=65362, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1866
#29 0x00007f3de8529a81 in QKeyMapperPrivate::translateKeyEvent (this=0x174cfa0, keyWidget=keyWidget@entry=0x1cc4b10, event=event@entry=0x7ffff39ed490, grab=grab@entry=false) at kernel/qkeymapper_x11.cpp:1836
#30 0x00007f3de8500859 in QApplication::x11ProcessEvent (this=0x7ffff39edcc0, event=event@entry=0x7ffff39ed490) at kernel/qapplication_x11.cpp:3639
#31 0x00007f3de852c0b2 in x11EventSourceDispatch (s=0x1703e20, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#32 0x00007f3de61bdf05 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f3de61be248 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f3de61be304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007f3de6f8a016 in QEventDispatcherGlib::processEvents (this=0x16bab30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#36 0x00007f3de852c1ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#37 0x00007f3de6f5a38f in QEventLoop::processEvents (this=this@entry=0x7ffff39ed860, flags=...) at kernel/qeventloop.cpp:149
#38 0x00007f3de6f5a618 in QEventLoop::exec (this=this@entry=0x7ffff39ed860, flags=...) at kernel/qeventloop.cpp:204
#39 0x00007f3de6f5fcf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#40 0x00007f3de8484ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#41 0x00007f3de9336e8d in kdemain (argc=3, argv=<optimized out>) at ../../../kate/app/katemain.cpp:382
#42 0x00007f3de8f89ea5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=3, ubp_av=0x7ffff39ede48, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff39ede38) at libc-start.c:260
#43 0x0000000000400701 in _start ()

This bug may be a duplicate of or related to bug 311866.

Possible duplicates by query: bug 317235, bug 311866.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-09-03 20:01:39 UTC

*** This bug has been marked as a duplicate of bug 311866 ***