Bug 324440 - eclipse crashes in Oxygen::MenuStateData::menuItemIsActive(_GtkWidget*) const
Summary: eclipse crashes in Oxygen::MenuStateData::menuItemIsActive(_GtkWidget*) const
Status: RESOLVED DUPLICATE of bug 324438
Alias: None
Product: Oxygen
Classification: Plasma
Component: gtk2-engine (show other bugs)
Version: unspecified
Platform: Kubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-03 05:02 UTC by Jürgen Richtsfeld
Modified: 2013-09-03 14:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Richtsfeld 2013-09-03 05:02:56 UTC
using eclipse kepler 64bit with oracle jvm and subclipse integration (javahl):
1) show history of a file
2) mark 2 revisions
3) context-menu: compare

eclipse very often crashes with:

#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f8cee6e616c, pid=19673, tid=140244722247424
#
# JRE version: 7.0_21-b11
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.21-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [liboxygen-gtk.so+0x7416c] Oxygen::MenuStateData::menuItemIsActive(_GtkWidget*) const+0x1c
#
# Core dump written. Default location: /home/juergen/core or core.19673
#
# An error report file with more information is saved as:
# /home/juergen/hs_err_pid19673.log
#
# If you would like to submit a bug report, please visit:
# http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.


see original report: https://bugs.launchpad.net/ubuntu/+source/gtk2-engines-oxygen/+bug/1219844

Reproducible: Always

Steps to Reproduce:
1) show history of a file
2) mark 2 revisions
3) context-menu: compare
Comment 1 Hugo Pereira Da Costa 2013-09-03 12:02:01 UTC

*** This bug has been marked as a duplicate of bug 324438 ***
Comment 2 Hugo Pereira Da Costa 2013-09-03 14:31:57 UTC
Could you post a 'dummy' eclipse project that I could edit so that I can try reproduce the bug exactly ? So far no luck.