Bug 324437 - vsync to wrong refresh rate upon reboot/login with nvidia driver causing tearing
Summary: vsync to wrong refresh rate upon reboot/login with nvidia driver causing tearing
Status: RESOLVED DUPLICATE of bug 322060
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-window-management (show other bugs)
Version: 4.11.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-03 01:35 UTC by noons
Modified: 2013-09-03 15:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description noons 2013-09-03 01:35:06 UTC
Running kde 4.11 under arch with nvidia 320.x series driver. Whenever I reboot/logout, then login to kde vsync syncs to 100hz (my monitor only supports 60hz) causing tearing regardless of which vsync method is chosen. The only way to resolve the issue is to change the compositor type opengl 2.0 > 3.0 or vice versa, or turn off vsync and then turn vsync back on. After doing so the fps applet reports a proper 60hz sync and tearing stops. After enabling the fps applet and testing a few scenarios it appears to startup at the proper 60hz, then about 20 seconds later it shoots to 100hz and doesnt get resolved until the steps mentioned above..

After some googling it appears this user using opensuse /nvidia is having the exact same problem. 

http://forums.opensuse.org/english/get-technical-help-here/applications/489685-kde-4-11-final-regressions.html

I do not have this issue with my desktop running built in intel graphics. 

Reproducible: Always

Steps to Reproduce:
1. System with nvidia drivers with proper vsync settings
2. Either logout or reboot system
3. 
Actual Results:  
vsync syncs to 100hz rather then the set refresh rate until you disable re-enable vsync in settings.

Expected Results:  
vsync should always sync to set refresh rate.
Comment 1 Thomas Lübking 2013-09-03 13:57:23 UTC
Tearing prevention is just disabled.

reason: bug #322060
patch (for misdetected triple buffering support): https://git.reviewboard.kde.org/r/112368/

*** This bug has been marked as a duplicate of bug 322060 ***
Comment 2 noons 2013-09-03 15:32:46 UTC
Thanks Thomas! I am glad it has already been addressed, now for wait.

(In reply to comment #1)
> Tearing prevention is just disabled.
> 
> reason: bug #322060
> patch (for misdetected triple buffering support):
> https://git.reviewboard.kde.org/r/112368/
> 
> *** This bug has been marked as a duplicate of bug 322060 ***