Bug 324348 - Add alt+tab-like tab switching
Summary: Add alt+tab-like tab switching
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: application (show other bugs)
Version: 3.10.5
Platform: Debian testing Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-01 10:51 UTC by wolpi.dev
Modified: 2014-09-14 17:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wolpi.dev 2013-09-01 10:51:28 UTC
When switching windows with alt+tab it happens in a recently used manner.

Kate provides commands to move to next/previous document. So I can get that recently used switching by using two different shortcuts. But I would prefer to have just one command and hence one shortcut.

In previous versions there was a plugin for that which also showed a tab-list-window.

I'm using Debian testing and recently I got an update to 
KDE 4.10.5
Kate 3.10.5
Editor Component 3.7


Reproducible: Always
Comment 1 Dominik Haumann 2013-09-02 07:36:20 UTC
Ctrl+Alt+o (quick open) is what you are looking for, right? It uses a least-recently-used list.
Comment 2 wolpi.dev 2013-09-03 17:34:24 UTC
(In reply to comment #1)
> Ctrl+Alt+o (quick open) is what you are looking for, right? It uses a
> least-recently-used list.

That is basically the same as the "tab-list" of the old plugin I mentioned.

What I really want is a single short cut to switch to the last used open file, exactly the way it is done for windows when pressing alt+tab.

With quick open I have to press Return additonally to actually switch to the last file.


Other issues are:
- switching in the opposite direction (for windows you can do that with alt+shift+tab)
- switching further than just the last file (for windows you can do that with alt+tab, tab, ... (keep alt pressed and press tab several times))

Under MS Windows it is pretty common for editors to have that functionallity assigned with ctrl+tab and ctrl+shift+tab.


For now I have assigned ctrl+tab to quick open, that is a workaround I can live with.
Comment 3 Gregor Mi 2013-11-30 14:34:14 UTC
(In reply to comment #2)
> Under MS Windows it is pretty common for editors to have that functionallity
> assigned with ctrl+tab and ctrl+shift+tab.

...not only in MS Windows editors but also in kdevelop. :) I switched from Windows to Linux and I am also missing the Ctrl+(Shift)+Tab shortcut in kate. Ctrl+Tab also works in other applications like Mozilla Firefox but out of the box not in a most recently used manner, though.

> For now I have assigned ctrl+tab to quick open, that is a workaround I can
> live with.

Good idea. That prevents inserting tabs when Ctrl+Tab is pressed out of habit.
Comment 4 Gregor Mi 2013-12-08 14:38:53 UTC
What about to assign Ctrl+Tab as additional default alternate shortcut to Ctrl+Alt+o? That would immediately help new users until the "Ctrl+(Shift)+Tab behaviour" can be implemented.

See also experience from a former kdevelop user: http://alt.my/2012/03/switching-tabs-in-kde-kate/

Ctrl+(Shift)+Tab seems to be standard not only in Windows but also in Mac: https://bugs.kde.org/show_bug.cgi?id=104997#c35
Comment 5 Ganton 2013-12-16 23:37:36 UTC
> ...not only in MS Windows editors but also in kdevelop. :) I switched from Windows to Linux and I am also missing the Ctrl+(Shift)+Tab shortcut in kate. 

It's also used in Linux in QtCreator :-). I miss the Ctrl+(Shift)+Tab shortcut in Kate, too. It's very useful! You go from the present document to the last one, and back; without going looking through all the file list. You just use a hotkey. 

It's as useful as using Alt+(Shift)+Tab once, instead of keeping pressed Alt and having to press Tab until you arrive to the desired window.

If you please, vote for this bug to be solved :-).
Comment 6 Gregor Mi 2013-12-18 16:39:30 UTC
Git commit cdf3c1955036b0216dd7a21d7ccfecfec4346271 by Gregor Mi.
Committed on 18/12/2013 at 16:39.
Pushed by gregormi into branch 'master'.

Set the default alternate shortcut for "Quick open" action

REVIEW: 114528

M  +4    -1    kate/app/katemainwindow.cpp

http://commits.kde.org/kate/cdf3c1955036b0216dd7a21d7ccfecfec4346271
Comment 7 Alex Turbov 2013-12-31 14:39:35 UTC
Git commit 2f59158e33fcb491ba3c63821a1d1c0990bfaeee by Alex Turbov.
Committed on 31/12/2013 at 14:37.
Pushed by turbov into branch 'master'.

REVIEW: 114749

Even more quick way to switch to a previous document: show opened docs
list (project files) only if user holds a `Ctrl` for awhile (~200ms),
otherwise just quick-quick-switch to a previous document w/o flikering
w/ widgets...

inspired by this

M  +25   -7    kate/app/katemainwindow.cpp
M  +2    -1    kate/app/katemainwindow.h
M  +17   -2    kate/app/katequickopen.cpp
M  +15   -3    kate/app/katequickopen.h

http://commits.kde.org/kate/2f59158e33fcb491ba3c63821a1d1c0990bfaeee
Comment 8 Dominik Haumann 2014-01-22 12:42:10 UTC
Git commit 3255ca929dd82e70a907cca66454e3a809c431bc by Dominik Haumann.
Committed on 22/01/2014 at 12:27.
Pushed by dhaumann into branch 'frameworks'.

revert: Even more quick way to switch to a previous document

This commit introduced too many regressions, e.g. the action View >
Quick Open did not work anymore

Revert:
Even more quick way to switch to a previous document: show opened docs
list (project files) only if user holds a `Ctrl` for awhile (~200ms),
otherwise just quick-quick-switch to a previous document w/o flikering
w/ widgets...

M  +7    -25   kate/app/katemainwindow.cpp
M  +8    -9    kate/app/katemainwindow.h
M  +2    -17   kate/app/katequickopen.cpp
M  +1    -13   kate/app/katequickopen.h

http://commits.kde.org/kate/3255ca929dd82e70a907cca66454e3a809c431bc
Comment 9 Dominik Haumann 2014-01-22 22:43:31 UTC
Git commit 9a80eb0443b1f04b8bbc6a46e241fe0c8470c3a3 by Dominik Haumann.
Committed on 22/01/2014 at 22:42.
Pushed by dhaumann into branch 'master'.

revert commit 2f59158e33fcb491ba3c63821a1d1c0990bfaeee

Revert (we need a special ctrl+tab switcher):
Even more quick way to switch to a previous document: show opened docs
list (project files) only if user holds a `Ctrl` for awhile (~200ms),
otherwise just quick-quick-switch to a previous document w/o flikering
w/ widgets...

M  +7    -25   kate/app/katemainwindow.cpp
M  +1    -2    kate/app/katemainwindow.h
M  +2    -17   kate/app/katequickopen.cpp
M  +3    -15   kate/app/katequickopen.h

http://commits.kde.org/kate/9a80eb0443b1f04b8bbc6a46e241fe0c8470c3a3
Comment 10 Dominik Haumann 2014-09-14 17:41:08 UTC
This is implemented as an additional Document Switcher plugin, available in Kate version >= 5.0. A screenshot can be found here: http://kate-editor.org/2014/09/13/kate-and-ktexteditor-5-after-akademy-2014/