Bug 324241 - Files generated with QTextDocument can't be opened with okular
Summary: Files generated with QTextDocument can't be opened with okular
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: ODT backend (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-29 22:51 UTC by Aleix Pol
Modified: 2013-12-15 23:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.11.5


Attachments
here's a file to reproduce the problem (1.25 KB, application/vnd.oasis.opendocument.text)
2013-08-29 22:52 UTC, Aleix Pol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aleix Pol 2013-08-29 22:51:21 UTC
Whenever I try to use okular to open those, I get an error message saying that the styles.xml file is missing: http://simplest-image-hosting.net/png-0-g17900

Reproducible: Always
Comment 1 Aleix Pol 2013-08-29 22:52:14 UTC
Created attachment 82020 [details]
here's a file to reproduce the problem

LibreOffice can open it
Comment 2 Albert Astals Cid 2013-12-15 23:19:36 UTC
Git commit 96c78eae6facd44125fcb5b69a9ba15917eef3d5 by Albert Astals Cid.
Committed on 15/12/2013 at 23:18.
Pushed by aacid into branch 'KDE/4.11'.

odt: Seems styles.xml and meta.xml are not mandatory

At least libreoffice opens the file from bug 324241 that has neither of them.
With this change we open it too, it looks crap when compared to libreoffice,
but that's just because our ooo generator needs to die in favour of a calligra one.
FIXED-IN: 4.11.5

M  +1    -1    generators/ooo/converter.cpp
M  +14   -20   generators/ooo/document.cpp
M  +6    -0    generators/ooo/styleparser.cpp

http://commits.kde.org/okular/96c78eae6facd44125fcb5b69a9ba15917eef3d5