Bug 324190 - VSync is lost shortly after startup
Summary: VSync is lost shortly after startup
Status: RESOLVED DUPLICATE of bug 322060
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: 4.11.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-28 22:56 UTC by t.jp
Modified: 2013-08-28 23:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description t.jp 2013-08-28 22:56:17 UTC
After KDE starts and the desktop is visible windows begin to tear after about 4 seconds. This is also noticable when having the FPS counter loaded on startup. It will initially be capped at 60 but rise above the monitors refresh rate at one point. To fix it I have to change the compositor from OpenGL 3.1 to 2.0. After that everything is as expected even when I change back to OpenGL 3.1. This also happens, when OpenGL 2.0 or 1.2 is set as default on startup. I have the vsync setting on "Automatic" but this behavior is also present when selecting "Fullscreen repaint".

I have this problem on two Arch Linux systems. One with NVIDIA 580 GPU and 325.15 driver and an older laptop with NVIDIA 6150 Go GPU and 304.108 driver.

Reproducible: Always

Steps to Reproduce:
1. Enable FPS counter and reboot.
2. Right after startup open a terminal window and start dragging it around and watch the FPS counter.

Actual Results:  
Window won't show any tearing for the first 3-4 seconds, but starts to tear after that.

Expected Results:  
VSync will stay on for the entire session.
Comment 1 Thomas Lübking 2013-08-28 23:28:27 UTC

*** This bug has been marked as a duplicate of bug 322060 ***