Bug 324103 - scam detection does not ignore missing protocol
Summary: scam detection does not ignore missing protocol
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: 4.11
Platform: Archlinux Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-27 08:37 UTC by meyerm
Modified: 2013-09-01 08:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description meyerm 2013-08-27 08:37:12 UTC
The new scam detection (very cool!) (see bug #289703 or bug #307818) does not take missing protocols into account. So the mail text says "Got to www.example.com!" and the link leads to "https://www.example.com". While this is the intended domain, of course, the scam detection plugin complains about possible scam. While I know what it means, people without the technical knowledge could be confused and a) delete the mail or (even worse) b) ignore the warning in the future.

Reproducible: Always

Steps to Reproduce:
1. open HTML mail with links without protocol in the visibile text
2. scam detection plugin complains about possible scam
3. ignore warning or dump mail


Expected Results:  
The plugin should at least ignore it when the protocol is missing in the text. This is surely not the only exception where the plugin should not "fire", but at least a very obvious one.

Of course the protocol should not be ignored when the text says "https://" and the link points to "http://". ;-)
Comment 1 Laurent Montel 2013-08-27 10:13:30 UTC
Effectly I need to fix it.
Will do soon.
Comment 2 Laurent Montel 2013-09-01 08:17:17 UTC
Git commit 84e643ee57f020cf27658ccc8e5dfbe443eb34f9 by Montel Laurent.
Committed on 01/09/2013 at 08:16.
Pushed by mlaurent into branch 'KDE/4.11'.

Fix Bug 324103 - scam detection does not ignore missing protocol

FIXED-IN: 4.11.2

M  +16   -6    messageviewer/scamdetection/scamdetection.cpp

http://commits.kde.org/kdepim/84e643ee57f020cf27658ccc8e5dfbe443eb34f9