Bug 324063 - contact edit dialog has too narrow fields
Summary: contact edit dialog has too narrow fields
Status: RESOLVED FIXED
Alias: None
Product: kaddressbook
Classification: Unclassified
Component: general (show other bugs)
Version: 4.11
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-26 11:31 UTC by Martin Koller
Modified: 2013-10-07 05:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.3


Attachments
screenshot of contact edit dialog (55.96 KB, image/png)
2013-08-26 11:32 UTC, Martin Koller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2013-08-26 11:31:54 UTC
When creating a new contact or editing an existing one a dialog with the details is opened.
This dialog has much too narrow fields for the Name and  for the phone entries.
See attached screenshot

Reproducible: Always
Comment 1 Martin Koller 2013-08-26 11:32:59 UTC
Created attachment 81940 [details]
screenshot of contact edit dialog
Comment 2 Martin Koller 2013-08-26 11:34:14 UTC
.. and the "Photo" button is overlapping the bottom line of the group box
Comment 3 Allen Winter 2013-09-17 17:51:01 UTC
Martin,
You should be able to resize the dialog to your preference and that new size will be saved/restored now (since 4.11.1)

we could also make the default initial size larger. currently set to 800x500.  maybe 900 wide would be better.
Comment 4 Martin Koller 2013-09-17 20:51:53 UTC
The size does not get restored here (4.11.1). Is it in 4.12 ?
Probably also the stretch factors should give more importance to the Name Group Box over the Internet Group Box.
Comment 5 Laurent Montel 2013-10-06 07:13:37 UTC
I confirm we can save/restore. (47ddd28a459ffab062da9a2bda15c566528b87a2)
Comment 6 Martin Koller 2013-10-06 12:02:34 UTC
ok, restoring works now in 4.11.2.
Still 2 open issues:
1.) The default width for mentioned fields is too narrow
2.) the "Photo" button is overlapping the bottom line of the group box
Comment 7 Laurent Montel 2013-10-06 12:13:57 UTC
Ok will look at default size this week.
Comment 8 Laurent Montel 2013-10-07 05:47:42 UTC
Git commit 8a3ef534cc7d9da4d2a389cd84ad90a662682abb by Montel Laurent.
Committed on 07/10/2013 at 05:47.
Pushed by mlaurent into branch 'KDE/4.11'.

Fix Bug 324063 - contact edit dialog has too narrow fields

FIXED-IN: 4.11.3

M  +1    -0    akonadi/contact/editor/contacteditorwidget.cpp

http://commits.kde.org/kdepimlibs/8a3ef534cc7d9da4d2a389cd84ad90a662682abb