Bug 324028 - Menu bar is missing after closing digiKam in fullscreen mode
Summary: Menu bar is missing after closing digiKam in fullscreen mode
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Menus (show other bugs)
Version: 4.2.0
Platform: Ubuntu Packages Linux
: NOR normal with 61 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2013-08-25 20:43 UTC by Thomas Bleher
Modified: 2017-08-02 21:08 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Bleher 2013-08-25 20:43:15 UTC
When closing digikam in fullscreen mode, digikam will remember that the menu bar is not visible (MenuBar=Disabled in digikamrc). On next startup, the menubar stays hidden, even when not in fullscreen mode. The user has to already know the shortcut for enabling the menu (Ctrl-M) or edit the config file.
The same happens to the status bar.

This makes Digikam basically unusable after accidentally exiting in full screen mode (except if one knows the magic shortcut key to re-enable the menu). I think publishing an update (3.3.1) would be nice.

Reproducible: Always

Steps to Reproduce:
1. Open digikam; make sure menu bar is there
2. Enter fullscreen mode
3. Close digikam (via Alt-F4)
4. Reopen digikam
Actual Results:  
Menu bar is hidden

Expected Results:  
Menu bar is shown

Package is from the kubuntu-backports ppa.
Comment 1 Shlomi Fish 2013-08-28 18:33:43 UTC
I can reproduce that problem here (on Mageia Linux Cauldron x86-64 ).
Comment 2 tblu 2013-11-02 13:47:37 UTC
I can reproduce it  on Sabayon Linux x86-64
Comment 3 caulier.gilles 2013-11-02 13:50:40 UTC
Which version of digiKam ?

Gilles Caulier
Comment 4 Shlomi Fish 2013-11-02 14:08:17 UTC
(In reply to comment #3)
> Which version of digiKam ?
> 

Tested with digikam from git master - the bug is there.

Regards,

-- Shlomi Fish
Comment 5 Christian Mayer 2014-01-03 23:14:17 UTC
The same happens when digikam crashed or was killed.

Apart from beeing annoying it also made me wander what else might got corrupted during the digikam crash...
Comment 6 caulier.gilles 2014-06-29 20:15:12 UTC
*** Bug 336874 has been marked as a duplicate of this bug. ***
Comment 7 AT 2014-09-05 22:21:31 UTC
Can confirm bug for Digikam 4.2.0 on KDE 4.13.3 and Sabayon Linux.
Comment 8 caulier.gilles 2014-09-06 08:48:50 UTC
Git commit 2b10a785f14cc1824d7f8f6efa9da7e0730a0dfa by Gilles Caulier.
Committed on 06/09/2014 at 08:46.
Pushed by cgilles into branch 'master'.

Restoring fullscreen mode between session is the hell. Something goes wrong from KDELibs when application action state are restored from XML GUI. It sound like a lots of KDE application hve this problem.
The work around this problem is to shutdown full-screen mode when digiKam is down. This store right action state in XML GUI settings file.
FIXED-IN: 4.3.0

M  +2    -1    NEWS
M  +2    -1    digikam/main/digikamapp.cpp
M  +9    -1    libs/widgets/mainview/dxmlguiwindow.cpp
M  +2    -6    libs/widgets/mainview/dxmlguiwindow.h
M  +1    -0    utilities/imageeditor/main/imagewindow.cpp
M  +2    -0    utilities/importui/main/importui.cpp
M  +1    -0    utilities/lighttable/lighttablewindow.cpp
M  +1    -0    utilities/queuemanager/main/queuemgrwindow.cpp

http://commits.kde.org/digikam/2b10a785f14cc1824d7f8f6efa9da7e0730a0dfa
Comment 9 AT 2014-09-09 05:44:56 UTC
Hi there,

can confirm seems to be KDE problem, just noticed is happening with Okular as well when shutting system down while in full screen mode. Or at least, that's what I assume is happening, haven't had the time yet to double check.
Comment 10 caulier.gilles 2014-09-09 05:57:11 UTC
yes, i can reproduce this problem with other KDE application which support fullscreen mode.

Please report this problem to KDELibs. I suspect the problem is located in class KXmlGuiWindow.

Gilles Caulier