Bug 323898 - No desktop effects after KDE 4.11 update, catalyst-legacy
Summary: No desktop effects after KDE 4.11 update, catalyst-legacy
Status: RESOLVED DUPLICATE of bug 323527
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.11.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-22 16:08 UTC by omeringen
Modified: 2013-08-22 17:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description omeringen 2013-08-22 16:08:52 UTC
Hi,
After KDE 4.11 update, i have lost the desktop effects. No crash.

Using HD2400, installed catalyst-legacy from unofficial repo, followed the instructions at [url=https://wiki.archlinux.org/index.php/AMD_Catalyst]catalyst wiki[/url].

Any information do you need except these ?
catalyst-hook 13.1-14
Linux arch 3.10.7-1-ARCH #1 SMP PREEMPT Thu Aug 15 11:55:34 CEST 2013 x86_64 GNU/Linux
KDE 4.11.00
[url=http://pastie.org/pastes/8260084/text]lspci[/url]
[url=http://pastie.org/pastes/8260090/text]file:///etc/X11/xorg.conf[/url]
[url=http://pastie.org/pastes/8260094/text]glxinfo[/url]
[url=http://pastie.org/pastes/8260097/text]qdbus org.kde.kwin /KWin supportInformation[/url]
[url=http://pastie.org/pastes/8260103/text]readelf -sw /usr/lib/libGL.so | grep glXGetFBConfigs[/url]

Reproducible: Always

Steps to Reproduce:
1.Go to the System Settings -> Desktop Effects and click on "Defaults" button and apply.
2.A message appears "19 desktop effects could not be loaded."
3.


Expected Results:  
It should load desktop effects without no problem. Works fine on KDE 4.10.
Comment 1 omeringen 2013-08-22 16:22:45 UTC
Sorry for the bbcode but i am not allowed to edit my message.
bTw, last sentence is incomplete. It's "Works fine on KDE 4.10.5"
Comment 2 Thomas Lübking 2013-08-22 16:30:47 UTC
most likely dupe.
try running kwin from konsole and look out for the enum and the gl1.2 init failure.

then enforce direct rendering and gl2

*** This bug has been marked as a duplicate of bug 323527 ***
Comment 3 omeringen 2013-08-22 17:05:06 UTC
(In reply to comment #2)
> most likely dupe.
> try running kwin from konsole and look out for the enum and the gl1.2 init
> failure.
> 
> then enforce direct rendering and gl2
> 
> *** This bug has been marked as a duplicate of bug 323527 ***

http://paste.kde.org/p7cb21a7e/
Comment 4 Thomas Lübking 2013-08-22 17:49:21 UTC
Is same bug, also see other dupe bug #323553