Bug 323835 - 'Tearing Prevention' does not survive reboot
Summary: 'Tearing Prevention' does not survive reboot
Status: RESOLVED DUPLICATE of bug 322060
Alias: None
Product: kwin
Classification: Unclassified
Component: core (show other bugs)
Version: 4.11.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-21 13:32 UTC by uo
Modified: 2013-08-28 09:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description uo 2013-08-21 13:32:31 UTC
I have an Nvidia GTX 660 and am using the proprietary drivers.

The tearing prevention settings do work but each time I reboot I get tearing again. The settings in that section are as they should be - I have to either change openGL versions or set vsync to 'none' and then back to what I previously had (I choose 'automatic', though it's the same for all options) in order to be rid of tearing.

To be clear: The settings do stick in the settings panel but they don't seem to do anything after a reboot. I have to disable and re-enable them or change GL version.

If it's of any relevance, I get a few seconds with no-tearing each time I boot. Then after a short while tearing starts. This was the same in 4.10 though in which I found no anti-tearing solution.

I would be glad to provide any further information that would be helpful.




Reproducible: Always

Steps to Reproduce:
1. Choose anti-tearing options which prevent teraring
2. Reboot
3. Settings are the same but tearing is back
4. Change settings to something else and back again: Tearing is gone
5. GOTO 2
Actual Results:  
Tearing is back after reboot

Expected Results:  
Tearing not to return after reboot
Comment 1 Thomas Lübking 2013-08-21 14:45:20 UTC
Please see dupe.
If you've Triple buffering enabled (or decide to do so), enforce it - otherwise ensure to 'export __GL_YIELD="USLEEP"'

*** This bug has been marked as a duplicate of bug 322060 ***
Comment 2 uo 2013-08-21 15:20:27 UTC
Thanks for the info, Thomas. I did search but didn't find that other bug.

And thanks for the workaround, enabling triple buffering did the trick.