Bug 323817 - Opengl 3.1 setting gets lost after reboot
Summary: Opengl 3.1 setting gets lost after reboot
Status: RESOLVED DUPLICATE of bug 322060
Alias: None
Product: kwin
Classification: Unclassified
Component: scene-opengl (show other bugs)
Version: 4.11.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 323818 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-21 06:12 UTC by Felix Michel
Modified: 2013-08-21 14:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Michel 2013-08-21 06:12:44 UTC
When I set compositing to opengl 3.1 i have no tearing and kwin is fast and slick. when i reboot i have some tearing and kwin is little bit slower, still fast. the problem is the tearing when scrolling or watching a full screen flash video. it seems that after the reboot the settings are changed back to opengl 2.0. I have an nvidia graphics card.

Reproducible: Always

Steps to Reproduce:
1. Set compositing type to opengl 3.1, no tearing
2. Reboot
Actual Results:  
after reboot there is again tearing.

Expected Results:  
the compositing type opengl 3.1 should be activated also after reboot.
Comment 1 Felix Michel 2013-08-21 06:22:45 UTC
*** Bug 323818 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Lübking 2013-08-21 09:42:02 UTC
This has nothing to do with the GL version (if actually reset that's either due to HW support or a different bug) but a problem to reliably detect the availability of triple buffering. see dupe.

*** This bug has been marked as a duplicate of bug 322060 ***
Comment 3 Felix Michel 2013-08-21 09:48:53 UTC
well, what i dont get then why do i have a performance and a tearing difference? no tearing if i reset the opengl option, but the tearing is present again when i reboot.
Comment 4 Thomas Lübking 2013-08-21 14:49:37 UTC
(In reply to comment #3)
> well, what i dont get then why do i have a performance and a tearing
> difference?

Did you read across the dupe?
In a nutshell: triple buffering is (likely) misdetected during login. Without either it or usleep yielding, swapping causes high cpu load, so it's forcefully deactivated.

W/o triple buffering, also chances raise to drop or miss a frame (because we stay in event processing as long as possible) and the event processing time naturally shortens as well -> seems slower.

-> Ensure to activate triple buffering and override the detection.