Bug 323648 - Plugins cannot be deselected
Summary: Plugins cannot be deselected
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Setup-Plugins (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-17 17:53 UTC by vato
Modified: 2019-01-04 10:18 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vato 2013-08-17 17:53:36 UTC
After deselecting kipi-plugins in the options, as expected, they do not appear in the menus or context menus. After restarting digikam though, the plugins are visible in the menus and in the options again. The strange thing is, that in the digikamrc the deselected plugins are marked as =false. It seems that Digikam is not reading digikamrc.

Reproducible: Always

Steps to Reproduce:
1. Deselect some (or all) kipi-plugins in the options.
2. Check the menus or context menus and see that the deselected plugins do not appear.
3. Restart Digikam
4. Check the menus or context menus and options and see that the deselected plugins appear.
Comment 1 vato 2013-09-10 05:01:56 UTC
Not fixed in Digikam 3.4.0.
Comment 2 caulier.gilles 2013-09-12 11:03:26 UTC
Git commit 53b1a92b96363c05584ba6f9bd8b68ec6fd2a06a by Gilles Caulier.
Committed on 12/09/2013 at 11:01.
Pushed by cgilles into branch 'master'.

miss to sync config to record KIPI plugins list into client application RC file
FIXED-IN: 3.5.0

M  +2    -0    libkipi/configwidget_p.cpp

http://commits.kde.org/libkipi/53b1a92b96363c05584ba6f9bd8b68ec6fd2a06a
Comment 3 caulier.gilles 2013-10-24 10:00:37 UTC
*** Bug 326556 has been marked as a duplicate of this bug. ***
Comment 4 vato 2013-11-06 01:58:03 UTC
The problem persists in Digikam 3.5.0.
Comment 5 caulier.gilles 2013-11-06 06:38:18 UTC
It fixed in libkipi released through kdegraphics component, not digiKam...

You need to update KDE.

Gilles Caulier
Comment 6 caulier.gilles 2013-11-18 05:49:30 UTC
*** Bug 327743 has been marked as a duplicate of this bug. ***
Comment 7 Brylie Christopher Oxley 2014-05-09 10:41:58 UTC
What version of libkipi/kdegraphics fixes the problem? I am using KDE SC 4.13 and have a problem with the MediaWiki export not showing up.
Comment 8 caulier.gilles 2014-05-09 11:14:44 UTC
This verion must do the stuff, but kipirc config file must be cleaned if i remember...

Gilles Caulier
Comment 9 Brylie Christopher Oxley 2014-05-09 11:23:18 UTC
There does no appear to be any entries in my kipirc related to MediaWiki export, which is what my original issue describes. I am not sure that the original issue is related to, or a duplicate of, this issue.
https://bugs.kde.org/show_bug.cgi?id=327743