Bug 323631 - Screen locker password input element loses focus when I change the active keyboard layout
Summary: Screen locker password input element loses focus when I change the active key...
Status: RESOLVED DUPLICATE of bug 319935
Alias: None
Product: kscreensaver
Classification: Unclassified
Component: locker-qml (show other bugs)
Version: 4.10.5
Platform: Archlinux Packages Linux
: NOR minor with 10 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-17 10:30 UTC by Someone
Modified: 2013-08-29 20:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Someone 2013-08-17 10:30:58 UTC
I'm using two keyboard layouts - English and Russian. Sometimes lock screen has Russian layout as active, so I change it to English (using hotkey alt+shift) and fastly typing my password. But every time I see that this password input element loses focus, so I have to click on it and type the password again. It is very annoying.

Reproducible: Always

Steps to Reproduce:
1. Make sure you have two keyboard layouts enabled
2. Go to the lock screen
3. Change your active keyboard layout using hotkey
Actual Results:  
Input element loses focus (is not active any more)

Expected Results:  
After I change the keyboard layout it should focus back to the password input element, or not to lose focus at all.
Comment 1 Someone 2013-08-17 10:35:10 UTC
Looks like it loses focus even if I just press ALT button
Comment 2 Christoph Feck 2013-08-29 20:24:33 UTC

*** This bug has been marked as a duplicate of bug 319935 ***