Bug 323623 - DAV-ressource should detect network status instead of spreading error notifications if there is no network
Summary: DAV-ressource should detect network status instead of spreading error notific...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: DAV Resource (show other bugs)
Version: 4.11
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-17 04:16 UTC by m.wege
Modified: 2017-01-07 23:33 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2013-08-17 04:16:45 UTC
I am using the DAV-resource with Owncloud. What makes it really annoying to use is the fact, that is obviously is not able to handle situations when there is not network. The notifications area is spamed. I think there is no need for me to be notified. The resource should just detect the network status and act upon it, meaning just waiting until the network is restored. In most of the cases I already know that the network is gone, so no notification is needed.

Reproducible: Always
Comment 1 Grégory Oestreicher 2013-09-03 20:04:35 UTC
Actually the resource is aware of the network connection status by using Solid (IIRC what was explained on IRC). This only monitors the status of the interfaces of your box, so if the problem lies further downstream (such as if your router lost its connection to its gateway) there's no way for the resource to be aware of it.

Which of those case are you in?
Comment 2 m.wege 2013-09-03 21:58:12 UTC
I mainly had this when I am using my 3G connection. But also when the system starts up and the connection is still build. I also had this problem on wireless networks which require a login

The main annoying part is the fact that there is not one but several error messages and also that that it makes a sound. Which of course I could turn of, but I would consider this a general problem. If there is a problem the error message should be less intruding, because in most of the cases it wont matter since the network will be restored.
So my suggestion would be only to notify the user if the problem exists for a longer time (x min). X may be 10 min. And then only one notification for all resources. May be after another x min another and so on.
Comment 3 Erik Quaeghebeur 2014-08-13 14:58:00 UTC
(In reply to m.wege from comment #2)
> I mainly had this when I am using my 3G connection. But also when the system
> starts up and the connection is still build. I also had this problem on
> wireless networks which require a login
> 
> The main annoying part is the fact that there is not one but several error
> messages and also that that it makes a sound. Which of course I could turn
> of, but I would consider this a general problem. If there is a problem the
> error message should be less intruding, because in most of the cases it wont
> matter since the network will be restored.
> So my suggestion would be only to notify the user if the problem exists for
> a longer time (x min). X may be 10 min. And then only one notification for
> all resources. May be after another x min another and so on.

I can second this request: whenever my upstream link to the internet breaks (temporarily) or whenever I am on a network where no full connection to the internet exists, a superfluous number of notification messages appears.
Comment 4 Denis Kurz 2016-09-24 20:43:29 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 5 Erik Quaeghebeur 2016-09-25 10:02:36 UTC
(In reply to Denis Kurz from comment #4)
> This bug has only been reported for versions older than KDEPIM 4.14 (at most
> akonadi-1.3). Can anyone tell if this bug still present?
> 
> If noone confirms this bug for a recent version of akonadi (part of KDE
> Applications 15.08 or later), it gets closed in about three months.

I can confirm this bug for akonadi-1.13.1_pre20160203, which is the stable version on Gentoo (15.08 is neither in testing or masked, 16.08.1 is available masked in an overlay, not in the main repository, meaning “still broken within Gentoo”). Kdepim is at version 4.14.11_pre20160211. I do not know whether a Frameworks 5 version will be available within 3 months.
Comment 6 Denis Kurz 2016-09-25 18:13:02 UTC
Erik, thanks for reporting back. I know that many users are still using 4.14, but we simply lack the manpower to keep up support for it. In fact, support has been dropped officially more two years ago, and KDE never gave any long term support guarantees for 4.14. Sorry to tell you that.

As for Gentoo: We might see a testing version of a Qt5/Framework-based PIM suite in the main portage tree (without kde overlay) after the release of 16.08.2 or 16.08.3, but not later than 16.12.0, so this might happen within 3 months.
Comment 7 Denis Kurz 2017-01-07 23:33:39 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.