Bug 323559 - Wish: Albums like Playlists in Amarok
Summary: Wish: Albums like Playlists in Amarok
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-TableView (show other bugs)
Version: 3.3.0
Platform: Kubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-15 19:16 UTC by pipoca
Modified: 2018-08-01 09:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pipoca 2013-08-15 19:16:09 UTC
Firstly, my compliments to the dev team: digiKam is an amazing app, and has features that, i believe, please even professionals.

Secondly, IMHO (I'm a newbie and not a professional), its albums concept - (sub-) directories with copies of the original pictures - is very poor and doesn't match the quality of the app. Amarok's playlists concept is much better, more practical and easier to understand and use: the files - which can have as many tags as in digiKam's - are stored where the user wants; when he/she wants to create a playlist, even with songs with mixed tags, just drags the files to the playlist area, reorders them at will and saves the playlist to the database with a meaningful term. Since a photo can "belong" to "n" albums, this approach is perfect: the file is "unique", but can be presented in a variety of contexts and situations.

My compliments again to the team for a superb job.

Reproducible: Always
Comment 1 caulier.gilles 2013-11-26 18:02:51 UTC
Michael,

It sound like this entry is implemented now with your TableView mode. Right ?

Gilles Caulier
Comment 2 Michael G. Hansen 2013-11-28 10:37:48 UTC
Hi Gilles,

I think this report is about a different concept: To create virtual albums, in which images can be placed and ordered as the user wishes, without moving the actual files, not so much about how they are displayed.

pipoca: Except for ordering the images in a user-defined way, you could use tags as the "albums" that you are referring to. Make a tag structure "Playlists->Name of Playlist" and assign those tags to your images. Then use the tag browser sidebar on the left hand side of digikam to browse your albums by tags.

Best regards,

Michael
Comment 3 caulier.gilles 2013-11-28 12:23:59 UTC
Michael,

you have right. There is already an old entry for this subject. It can be a future project for GoSC in the future...

Gilles

*** This bug has been marked as a duplicate of bug 91562 ***
Comment 4 caulier.gilles 2018-08-01 09:33:54 UTC
Git commit c6e92a02cfeebc86b60faad9442e780a7342abbf by Maik Qualmann.
Committed on 31/07/2018 at 19:46.
Pushed by mqualmann into branch 'master'.

fix and optimize manual sorting

M  +21   -13   core/app/items/digikamimageview.cpp
M  +0    -2    core/libs/database/coredb/coredb.cpp
M  +14   -2    core/libs/database/item/imageinfo.cpp
M  +1    -1    core/libs/database/item/imageinfo.h
M  +1    -1    core/libs/database/item/imageinfodata.h

https://commits.kde.org/digikam/c6e92a02cfeebc86b60faad9442e780a7342abbf