Bug 323531 - Double clicking on some files causes Konqueror to open a new Konqueror which opens a new Konqueror which opens a new Konqueror...(Ad infinitum)
Summary: Double clicking on some files causes Konqueror to open a new Konqueror which ...
Status: RESOLVED DUPLICATE of bug 318683
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-15 06:36 UTC by BryanFRitt
Modified: 2013-09-24 17:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BryanFRitt 2013-08-15 06:36:51 UTC
Double clicking on some files causes Konqueror to open a new Konqueror window which opens a new Konqueror window which opens a new Konqueror window...(Ad infinitum) 

Naturally one doesn't want an infinite number of Konqueror windows popping up. 

Before launching a program, Konqueror should check to make sure it won't start an infinite recursion of starting itself. Also there should be some checks on settings to make sure Konqueor is set up correctly so this problem doesn't occur.
-
To get rid of all these Konqueror windows one can do a 'Ctrl+Alt+F[1-6]' ...`killall konqueror`..., followed by a 'Ctrl+Alt+F[7-12]' to get back to KDE. Note this kills all konqueror windows, even the original.

Note: I haven't tried this with Dolphin, but this problem might occur there too.
Comment 1 Dawit Alemayehu 2013-08-22 11:54:55 UTC
Which types of files is this ? I just tried with images, pdf and text files and I cannot reproduce the problem. I cannot even get it to open two windows unless I quadruple click on the file.
Comment 2 BryanFRitt 2013-08-25 00:24:34 UTC
I don't remember which file type(s) it was. I know it happened a couple of times when I accidentally double clicked on a file. (like when I'm half asleep at my computer trying to find something) 

I do remember trying it again on the same file that this had just happened on and it did the same thing. Killing Konqueor this way, `killall konqueror`, closes the original window too, and it's been a while, so I'm not sure what I had clicked on now. (don't even remember what I was looking for, or doing)

When it happens, Konqueror opens Konqueror which opens Konqueoror (Ad infinitum) I've seen around a dozen or so Konqueror processes running, before doing the `killall konqueror`. It didn't appear that Konqueror windows were opening simultaneously, it appeared that when one would complete loading the next one start up.

If I come across this again, I'll try to make note of which file it was, and post which type it was, etc...
Comment 3 BryanFRitt 2013-09-24 17:41:47 UTC

*** This bug has been marked as a duplicate of bug 318683 ***