Bug 323498 - (Some) Image Editor Color tools hang when starting them
Summary: (Some) Image Editor Color tools hang when starting them
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Editor-AutoColors (show other bugs)
Version: 3.3.0
Platform: Kubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-14 15:25 UTC by xilef4040
Modified: 2017-08-07 07:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xilef4040 2013-08-14 15:25:06 UTC
Since updating digiKam to v3.3.0 I can no longer open the following tools in the Image Editor:
- Brightness, Contrast, Gamma
- Hue, Saturation, Lightness
- Color Balance
- Level Adjust
- Color Negative
- Black White
- White Balance
- Color Effects
They just hang with 0% progress. 

Especially adjusting the bridghtness belongs to the features of the Image Editor I and probably others use most. Please fix this.

Reproducible: Always

Steps to Reproduce:
1. Load any image in the image editor.
2. Select Tool -> Brightness, Gamma, Contrast
Actual Results:  
The cursor indicates loading. The progress bar in the lower left corner reads 0%. The tool panel on the right opens, but the sliders and buttons are greyed out. Only "Cancel" can be clicked, which closes the tool. This does not change even after a few minutes.

Expected Results:  
The tool should load up (in no time).
Comment 1 caulier.gilles 2013-08-14 15:30:32 UTC
Already fixed in for next 3.4.0 release.

Gilles Caulier