Bug 323476 - Sort akonadi resources by type
Summary: Sort akonadi resources by type
Status: RESOLVED FIXED
Alias: None
Product: kdepim
Classification: Applications
Component: libkdepim (show other bugs)
Version: 4.11
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-14 03:02 UTC by Volker Kuhlmann
Modified: 2019-06-20 05:07 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Kuhlmann 2013-08-14 03:02:53 UTC
System settings -> Personal info -> akonadi resources

The list of resources is messy and difficult to work with. It would help sorting the list by resource type, so all the imap ones are together, the contact ones are together, etc.

Even better might be a hierarchical display.

Reproducible: Always
Comment 1 Volker Kuhlmann 2013-08-16 21:57:54 UTC
This is particularly problematic when there are a dozen imap resources that all have to be checked because akonadi has yet another problem with them, and in between a longlist of other stuff they don't stand out.
The quick search bar at the top is useless for this because it can only search by resource name; typing "imap" gives an empty list.
Comment 2 Laurent Montel 2013-08-16 22:33:44 UTC
Will look at soon how to improve it
Comment 3 Volker Kuhlmann 2013-08-16 23:54:42 UTC
Thanks muchly!! I'm having big issues with akondai resources in general :-((, essentially not tracking sources sensibly. I'm working on reports.
Comment 4 Laurent Montel 2014-03-16 07:56:44 UTC
it's poswsible now to searchby type as pop3/imap etc.
Comment 5 Volker Kuhlmann 2014-03-16 23:07:29 UTC
Thanks! But did you mean search or sort? Both would be very useful, but are not the same.
Comment 6 Laurent Montel 2014-03-17 06:03:07 UTC
Search.
Comment 7 Volker Kuhlmann 2014-03-18 21:18:40 UTC
Sorry, no.
Searching for imap or email gives nothing.
Searching is useless if I don't know what I am searching for.
It is essential to have a complete list at a glance of what's configured, especially for something as haphazzard as akonadi, e.g. for troubleshooting. The current display is a mess and not user-friendly.
But if it's too difficult I rest my case.
Thanks!
Comment 8 Laurent Montel 2019-06-20 05:07:33 UTC
akonadi resource was removed.
We use akonadiconsole now and we can search without pb