Bug 323427 - Ambiguous license information
Summary: Ambiguous license information
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kdepasswd
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Geert Jansen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-12 19:33 UTC by Sam Geeraerts
Modified: 2021-03-14 20:11 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
mail.google.com.txt by Geert Jansen (1.75 KB, text/plain)
2013-12-30 21:57 UTC, Kevin Kofler
Details
Email response from Geert Jansen (4.11 KB, text/plain)
2015-12-13 20:07 UTC, Dennis Worthem
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Geeraerts 2013-08-12 19:33:15 UTC
The file kdepasswd.cpp contains ambiguous license information. The header comment has an X11 style license, but the KAboutData says "KAboutData::License_Artistic". It's not clear which of the 2 licenses applies.

Reproducible: Always
Comment 1 Christoph Feck 2013-08-13 22:34:24 UTC
Geert, could you please clarify this issue?
Comment 2 geertjan.projects 2013-09-10 18:56:11 UTC
Hello,

Sorry for the late reaction.

In the upgrade I did from Debian 6 to 7 I encoutered this error.
After reinstalling Debian 7 the problem didn't occur again.
The problem is probally a concequency in the update to Debian 7.

Best regards,

Geert Jan Klinkhamer


Christoph Feck schreef op di 13-08-2013 om 22:34 [+0000]:
> https://bugs.kde.org/show_bug.cgi?id=323427
> 
> Christoph Feck <christoph@maxiom.de> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |christoph@maxiom.de
>            Assignee|g.t.jansen@stud.tue.nl      |geertjan.projects@gmail.com
> 
> --- Comment #1 from Christoph Feck <christoph@maxiom.de> ---
> Geert, could you please clarify this issue?
>
Comment 3 Christoph Feck 2013-09-10 22:29:56 UTC
Sorry, wrong email address. I hope this is one right.

Geert, could you please clarify this issue?
Comment 4 Sam Geeraerts 2013-12-29 15:12:32 UTC
Is there any new information about this issue?

Because the Artistic License 1.0 is considered non-free by the FSF I've removed kdepasswd from the gNewSense distribution. I hope this is a temporary measure and that we can re-include it when this is clarified.
Comment 5 Christoph Feck 2013-12-29 17:16:09 UTC
If we could find a working address for Geert, it would help...
Comment 6 Kevin Kofler 2013-12-30 21:57:11 UTC
Created attachment 84355 [details]
mail.google.com.txt by Geert Jansen

Geert Jansen replied by e-mail:

> bug-control@kde.org bounces for me.
>
> My email is geertj@gmail.com. I've responded to this years ago. See
> attached email.
>
> Regards,
> Geert
Comment 7 Sam Geeraerts 2014-01-05 13:10:45 UTC
The MIT/X11 license is not defined in KAboutData. Should kdepasswd get a COPYING file and some create_license code like in kolourpaint?
Comment 8 Dennis Worthem 2015-12-07 04:16:10 UTC
Would it be possible to dual license this with (L)GPL v. 3?  That way we can use the enum for that license in KAboutData.
Comment 9 Dennis Worthem 2015-12-13 20:07:16 UTC
Created attachment 96047 [details]
Email response from Geert Jansen

In this email Geert Jansen agreed to dual license kdepasswd under MIT + LGPL (v2.1 or later)
Comment 10 Justin Zobel 2021-03-09 23:42:30 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 11 Sam Geeraerts 2021-03-14 20:11:11 UTC
It looks like this was never fixed in the source code, but it seems this application is no longer part of KDE, so I guess it's no longer relevant.