Bug 323296 - Deleting the currently filtered tags does not reset the filter
Summary: Deleting the currently filtered tags does not reset the filter
Status: RESOLVED FIXED
Alias: None
Product: Active
Classification: Unclassified
Component: Applications (show other bugs)
Version: Testing
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: PA 4
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-08 18:38 UTC by Thomas Pfeiffer
Modified: 2013-08-09 20:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Pfeiffer 2013-08-08 18:38:29 UTC
When filtering on a tag and deleting that tag, no files are shown anymore in Files because the filter is not reset, similarly to bug 323265

Reproducible: Always

Steps to Reproduce:
1. Open Files
2. Go to Tags
3. Tap a tag
4. Slide the tag sideways
5. Tap "Delete"
6. Confirm
Actual Results:  
The tag is deleted, Files shows no more files until it is restarted

Expected Results:  
The tag filter is cleared, all files of the selected type/Activity are shown again
Comment 1 Marco Martin 2013-08-09 13:10:27 UTC
Git commit 329cc8ff6e5b6fa1b1077bb0e8aa1ea24fc1b97a by Marco Martin.
Committed on 09/08/2013 at 13:09.
Pushed by mart into branch 'Active/4'.

unselect tag before deleting

M  +1    -0    applications/filebrowser/package/contents/ui/TagsBar.qml

http://commits.kde.org/plasma-mobile/329cc8ff6e5b6fa1b1077bb0e8aa1ea24fc1b97a
Comment 2 Marco Martin 2013-08-09 13:11:20 UTC
Git commit 100c9c12da95cd223461fde84f2b244bf11b3c01 by Marco Martin.
Committed on 09/08/2013 at 13:09.
Pushed by mart into branch 'master'.

unselect tag before deleting

M  +1    -0    applications/filebrowser/package/contents/ui/TagsBar.qml

http://commits.kde.org/plasma-mobile/100c9c12da95cd223461fde84f2b244bf11b3c01
Comment 3 Thomas Pfeiffer 2013-08-09 20:20:27 UTC
Yes, it works now :)