Bug 323191 - abort condition met in ungrabXServer() - induced by KillWindow::release, hardening patch in 4.11
Summary: abort condition met in ungrabXServer() - induced by KillWindow::release, hard...
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL: https://git.reviewboard.kde.org/r/111...
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-08-05 13:05 UTC by Alex Fiestas
Modified: 2021-12-07 04:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
mgraesslin: ReviewRequest+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Fiestas 2013-08-05 13:05:53 UTC
Application: kwin (4.11.60)
KDE Platform Version: 4.11.60 (Compiled from sources)
Qt Version: 4.8.6
Operating System: Linux 3.10.4-1-ARCH x86_64
Distribution: "Arch Linux"

-- Information about the crash:
Eventually while using spotify KWin will hang as in "mouse input won't arrive to applications" even though alt+tab and rendering still works.

Some input works as well, for example I can do alt+f2, kwin --replace and it works.

Sorry for yet another cryptic bug entry :/

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin), signal: Aborted
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f53838a51c9 in raise () from /usr/lib/libc.so.6
#7  0x00007f53838a65c8 in abort () from /usr/lib/libc.so.6
#8  0x00007f538389e356 in __assert_fail_base () from /usr/lib/libc.so.6
#9  0x00007f538389e402 in __assert_fail () from /usr/lib/libc.so.6
#10 0x00007f538bd0fd5c in KWin::ungrabXServer () at /home/afiestas/kde/source/kde-workspace/kwin/utils.cpp:218
#11 0x00007f538bd26c3a in KWin::KillWindow::release (this=0x10ed870) at /home/afiestas/kde/source/kde-workspace/kwin/killwindow.cpp:192
#12 0x00007f538bd26b52 in KWin::KillWindow::handleKeyPress (this=0x10ed870, keycode=65 'A', state=4096) at /home/afiestas/kde/source/kde-workspace/kwin/killwindow.cpp:174
#13 0x00007f538bd26918 in KWin::KillWindow::processEvent (this=0x10ed870, event=0x7fffef7d4b60) at /home/afiestas/kde/source/kde-workspace/kwin/killwindow.cpp:117
#14 0x00007f538bd2065b in KWin::Workspace::workspaceEvent (this=0x98dae0, e=0x7fffef7d4b60) at /home/afiestas/kde/source/kde-workspace/kwin/events.cpp:84
#15 0x00007f538bd17278 in KWin::Application::x11EventFilter (this=0x7fffef7d4e20, e=0x7fffef7d4b60) at /home/afiestas/kde/source/kde-workspace/kwin/main.cpp:414
#16 0x00007f5384fe97d5 in qt_x11EventFilter (ev=0x7fffef7d4b60) at /home/afiestas/kde/source/qt/src/gui/kernel/qapplication_x11.cpp:436
#17 0x00007f5384ff9560 in QApplication::x11ProcessEvent (this=0x7fffef7d4e20, event=0x7fffef7d4b60) at /home/afiestas/kde/source/qt/src/gui/kernel/qapplication_x11.cpp:3354
#18 0x00007f5385035cd7 in QEventDispatcherX11::processEvents (this=0x78d960, flags=...) at /home/afiestas/kde/source/qt/src/gui/kernel/qeventdispatcher_x11.cpp:132
#19 0x00007f538615edbb in QEventLoop::processEvents (this=0x7fffef7d4d70, flags=...) at /home/afiestas/kde/source/qt/src/corelib/kernel/qeventloop.cpp:149
#20 0x00007f538615ef4e in QEventLoop::exec (this=0x7fffef7d4d70, flags=...) at /home/afiestas/kde/source/qt/src/corelib/kernel/qeventloop.cpp:204
#21 0x00007f53861620f4 in QCoreApplication::exec () at /home/afiestas/kde/source/qt/src/corelib/kernel/qcoreapplication.cpp:1221
#22 0x00007f5384f58676 in QApplication::exec () at /home/afiestas/kde/source/qt/src/gui/kernel/qapplication.cpp:3823
#23 0x00007f538bd1840e in kdemain (argc=2, argv=0x7fffef7d5458) at /home/afiestas/kde/source/kde-workspace/kwin/main.cpp:589
#24 0x0000000000400a82 in main (argc=2, argv=0x7fffef7d5458) at /home/afiestas/kde/build/kde-workspace/kwin/kwin_dummy.cpp:3

Reported using DrKonqi
Comment 1 Thomas Lübking 2013-08-05 13:34:41 UTC
Run "kcmshell4 keys", select KWin and filter for "kill"
Is "Kill Window" assigned to some shortcut you might have invoked?

@Martin
Wasn't this thing up for removal?
Comment 2 Martin Flöser 2013-08-06 05:52:32 UTC
https://git.reviewboard.kde.org/r/111903/ might fix it in case the root problem was a failing keyboard grab
Comment 3 Martin Flöser 2013-08-06 12:45:38 UTC
Git commit 2864477a26f8f9ada5ebd6ae5a953ca3dd16c3d1 by Martin Gräßlin.
Committed on 06/08/2013 at 05:50.
Pushed by graesslin into branch 'KDE/4.11'.

Better activation check in KillWindow

If the grab keyboard fails we better do not activate the window killer
otherwise we are in an inconsistent state.
REVIEW: 111903

M  +5    -2    kwin/killwindow.cpp

http://commits.kde.org/kde-workspace/2864477a26f8f9ada5ebd6ae5a953ca3dd16c3d1
Comment 4 Andrew Crouthamel 2018-11-11 04:27:38 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Andrew Crouthamel 2018-11-21 04:29:07 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? This bug will be moved back to REPORTED Status for manual review later, which may take a while. If you are able to, please lend us a hand.

Thank you for helping us make KDE software even better for everyone!
Comment 6 kde.org 2021-11-07 10:25:15 UTC
This issue report is quite old. Can you please confirm, that it still persists with Plasma 5.23?
Comment 7 Bug Janitor Service 2021-11-22 04:38:42 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Bug Janitor Service 2021-12-07 04:36:23 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!