Bug 322987 - Rename "Save link" to "Save destination" or "Save target"
Summary: Rename "Save link" to "Save destination" or "Save target"
Status: RESOLVED UNMAINTAINED
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: 2.3.2
Platform: Kubuntu Packages Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-30 10:21 UTC by Bernd Oliver Sünderhauf
Modified: 2018-05-11 16:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Oliver Sünderhauf 2013-07-30 10:21:34 UTC
"Save Link" in the context menu should be "Save Destination" (or maybe "Save link destination"), because it's the referenced page being saved rather than the link or URL itself.

Because it does something completely different, it also shouldn't be grouped with "Copy Link".
Rather it's "Copy Link", "Bookmark link" and "Share link" which are doing similar things. So if subdividing is needed at all here, "Copy Link" should be grouped with the latter two.

In any case, "Save Destination" is used much less often than "Copy Link", so we should make sure "Copy Link" appears as the first item of a grouping.

Reproducible: Always



Expected Results:  
Either of these would be fine:

Proposal 1:
-------------
Open...
-------------
Copy Link
Bookmark Link
Share Link
Save Destination...
-------------


Proposal 2:
-------------
Open...
-------------
Copy Link
Bookmark Link
Share Link
-------------
Save Destination...
-------------


Proposal 3:
-------------
Open...
-------------
Save Destination...
-------------
Copy Link
Bookmark Link
Share Link
-------------
Comment 1 Bernd Oliver Sünderhauf 2013-07-30 10:37:56 UTC
The context menu of a linked image of course needs to be in line with this.
As in this case, the context menu has a few more options, proposal 1 (see above) might be preferable to keep things easy to grasp.

Also, the four link-related actions are torn apart in this case with some image-related action being placed in the middle, which is quite hard to grasp. IMHO, the link-related actions should stay together, with the image-related actions either preceding or trailing in a separate grouping. 

Such as:
------------
Open...
-------------
Copy Link
Bookmark Link
Share Link
Save Destination...
-------------
View Image
Save image as...
Copy image location
Share image location
Block image
-------------
Comment 2 Andrea Diamantini 2013-08-01 17:43:05 UTC
Git commit 8067811130022f2024558bda7be4a6760d2b9189 by Andrea Diamantini.
Committed on 01/08/2013 at 17:39.
Pushed by adjam into branch 'master'.

Contextual menu work

Group inspect action alone as requested and reorganized action as
proposed. Now we have

--- OPEN ACTION ---
open here
open there
open everywhere
--- SAVE ---
save link as..
--- LINK RELATED
copy link
bookmark link
share link
----
inspect
.

"Save link" is the text chosen in KDE, webkit, chrom* && firefox. I
don't want to change it.
Related: bug 322988

M  +5    -4    src/webtab/webview.cpp

http://commits.kde.org/rekonq/8067811130022f2024558bda7be4a6760d2b9189
Comment 3 Bernd Oliver Sünderhauf 2013-08-06 11:20:58 UTC
> "Save link" is the text chosen in KDE, webkit, chrom* && firefox. I don't want to change it.

True, however in IE and Opera it's named "Save target as...".
There's also a longstanding issue with Firefox: https://bugzilla.mozilla.org/show_bug.cgi?id=275475, and in the meantime some official translations (at least the German) have decided to use the equivalent of "Save target as...".
So it's not like there were no precedents, and semantically it remains the correct choice.

I slightly preferred "Save destination as..." but would be fine with either of "Save destination as..." or "Save target as...".
Tentatively reopening the issue for a potential followup.
Don't want to annoy you with it, though - you're responsiveness is outstanding, and I'm full of respect about the way you're maintaining Rekonq!
Comment 4 Nate Graham 2018-05-11 16:30:28 UTC
Development on Rekonq ceased four years ago, and it has been unmaintained since then. KDE recommends using Falkon instead.