Bug 322980 - Mounted USB devices are no longer visible on Amarok start
Summary: Mounted USB devices are no longer visible on Amarok start
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/USB mass storage and MSC (show other bugs)
Version: 2.7-git
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-30 08:53 UTC by Myriam Schweingruber
Modified: 2013-07-30 17:56 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Myriam Schweingruber 2013-07-30 08:53:01 UTC
Since yesterday, all mounted USB devices don't show anymore in the Collection Browser, they still did before I recompiled this morning.

Current amarok v2.7.90-68-g1b208a0

UMS collection enabled in the settings, 2 external USB HD mounted, one USB vfat key mounted, all devices show correctly in Dolphin, and show again when mounted once Amarok is started.

Regression: mounted USB devices should show in the collection browser on start.
Comment 1 Myriam Schweingruber 2013-07-30 08:53:41 UTC
FWIW: I didn't update KDE packages in between
Comment 2 Matěj Laitl 2013-07-30 12:57:11 UTC
This is the bug I've worked on with Alex at Akqdemy.

Alex, have you promised me to tell me a work-around so that we can still work fine with older KDE releases?

*** This bug has been marked as a duplicate of bug 317485 ***
Comment 3 Matěj Laitl 2013-07-30 17:53:07 UTC
Okay, let's make this a non-dupe as we're going to work-around it.
Comment 4 Matěj Laitl 2013-07-30 17:56:06 UTC
Git commit cfaa48278274f70fab3f6e1b610660edafbf7bbc by Matěj Laitl.
Committed on 30/07/2013 at 17:51.
Pushed by laitl into branch 'master'.

MediaDeviceCache: work-around Solid UDisks2 bug by not calling allDevices()

Kudos go to Alex Fiestas for extensive debugging and finding out the
root of the problem.

BUGFIXES:
 * Work-around Solid UDisks2 backend bug that caused USB Mass Storage
   devices and iPods not being recognized when connected before Amarok
   was started. Also fixes a bug where blank devices would appear in
   Play Media dialog. (BR 322980)

We don't need to call Solid::Device::allDevices() at all because that
was only needed for Apple iPhone support for the *old* iPod collection
that was replaced in Amarok 2.6.
Related: bug 317485
FIXED-IN: 2.8

M  +3    -0    ChangeLog
M  +0    -23   src/MediaDeviceCache.cpp

http://commits.kde.org/amarok/cfaa48278274f70fab3f6e1b610660edafbf7bbc