Bug 322931 - Akonadi postgresql backend ( qt 4.8.5+ )
Summary: Akonadi postgresql backend ( qt 4.8.5+ )
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: libakonadi (show other bugs)
Version: 4.10
Platform: OpenSUSE Linux
: NOR grave with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL: https://bugreports.qt-project.org/bro...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-29 06:00 UTC by Bruno Friedmann
Modified: 2013-10-04 12:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 1.10.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2013-07-29 06:00:56 UTC
With qt 4.8.5 or 5.0.1 the upstream patch (which look wrong)
destroy akonadi usage with postgresql

See my last two comments on https://bugreports.qt-project.org/browse/QTBUG-30076
(Also true for debian)

Reproducible: Always

Steps to Reproduce:
1. Install recent postgresql 9.2x
2. Install recent qt 4.8.5
3. Install recent kdepim ( 4.10 or +)
4. Create your database, and check postgresql logs.
Actual Results:  
   2013-07-16 17:51:52 EDT ERROR:  invalid input syntax for type bytea at
     character 24
   2013-07-16 17:51:52 EDT STATEMENT:  EXECUTE qpsqlpstmt_7d ('\SEEN')
   2013-07-16 17:51:52 EDT ERROR:  invalid input syntax for type bytea at
     character 24
   2013-07-16 17:51:52 EDT STATEMENT:  EXECUTE qpsqlpstmt_7d ('\SEEN')

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=716922
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=717117


Expected Results:  
No errors
Comment 1 Bruno Friedmann 2013-07-29 06:01:49 UTC
Could be linked to https://bugs.kde.org/show_bug.cgi?id=252120 
But is definitively not the same.
Comment 2 Christophe Marin 2013-07-29 19:15:37 UTC
I don't really see the reason to open a bug report here if you already know the regression comes from upstream :)
Comment 3 Bruno Friedmann 2013-07-31 04:48:12 UTC
If upstream decide they already fix it. Everybody think it's fixed, And it's not the case actually.
Downgrading to 4.8.4 will be soon a non option do "normal" users.

I would have kept the open status just to be sure to track down any change on upstream.
Comment 4 Lisandro Damián Nicanor Pérez Meyer 2013-10-03 12:38:45 UTC
Upstream has just closed the bug stating the the problem is in akonadi. See https://bugreports.qt-project.org/browse/QTBUG-30076?focusedCommentId=216330&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-216330
Comment 5 Bruno Friedmann 2013-10-03 14:40:55 UTC
So now we're sure it's not upstream : bug reopen.
Akonadi guy have to change their usage : use text and QText or Bytea and corresponding QT object
Comment 6 Daniel Vrátil 2013-10-04 12:18:42 UTC
Git commit 0a348cc98a458227bb28d89de584b61e31e1e9a8 by Dan Vrátil, on behalf of Cédric Villemain.
Committed on 04/10/2013 at 12:07.
Pushed by dvratil into branch '1.10'.

Map QString to text instead of Bytea with PostgreSQL backend

It's what suggested by QTSql.

It also happens to fix the recent issues raising around '\SEEN' errors
in SQL queries. It was visible because QTSql somewhat improve the postgresql
driver, and so... akonadi revealed its own bug.

REVIEW: 112976
Related: bug 252120
FIXED-IN: 1.10.3

M  +0    -7    server/src/storage/dbinitializer_p.cpp
M  +14   -0    server/src/storage/dbupdate.xml

http://commits.kde.org/akonadi/0a348cc98a458227bb28d89de584b61e31e1e9a8