Bug 322847 - Bug 313834 in reverse: virtuoso-6.1.7 fails with "NepomukStorage only works with virtuoso 6.1.6"
Summary: Bug 313834 in reverse: virtuoso-6.1.7 fails with "NepomukStorage only works w...
Status: RESOLVED FIXED
Alias: None
Product: nepomuk
Classification: Unclassified
Component: storage (show other bugs)
Version: 4.10.90
Platform: Fedora RPMs Linux
: NOR major with 20 votes (vote)
Target Milestone: ---
Assignee: Nepomuk Bugs Coordination
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-26 14:09 UTC by Alejandro Nova
Modified: 2013-08-02 01:41 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Nova 2013-07-26 14:09:26 UTC
Looks like we are asking for Virtuoso 6.1.6 and are ruling out any release AFTER 6.1.6. VOS 6.1.7 got released 2 days ago, and I tried to test it, with that result.

Reproducible: Always

Steps to Reproduce:
1. Install VOS 6.1.7
2. Try to restart nepomuk with nepomukctl restart
3. nepomukstorage will fail with this:

nepomukstorage(2355)/nepomuk (storage service): NepomukStorage only works with virtuoso 6.1.6 

Actual Results:  
Nepomuk works *only* with VOS 6.1.6, ruling out any bugfix release after 6.1.6

Expected Results:  
Nepomuk works with VOS 6.1.6 AND HIGHER.
Comment 1 Hrvoje Senjan 2013-07-26 14:21:02 UTC
@Alejandro, related to 6.1.7. I've been trying git snapshots of it, and result was that there is at least one regression - bug 320873. Further, creating db with 6.1.7 and then downgrading to 6.1.6, breaks nepomuk completely - all apps using it, lock up. Could be fixed meanwhile though...
Comment 2 Hrvoje Senjan 2013-07-26 16:49:35 UTC
OK, disabled the version check, and seems bug 320873 is gone with final 6.1.7. (sorry for spamming)