Bug 322656 - when opening a pic, dark areas show artefacts
Summary: when opening a pic, dark areas show artefacts
Status: RESOLVED NOT A BUG
Alias: None
Product: digikam
Classification: Unclassified
Component: ImageEditor-Canvas (show other bugs)
Version: 3.2.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-21 15:05 UTC by Axel Krebs
Modified: 2022-01-25 15:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments
screenshot showing misleading pattern (929.81 KB, image/png)
2013-07-21 15:07 UTC, Axel Krebs
Details
suspected pattern with reddish underlied lines (vertical and horizontal) (945.13 KB, image/png)
2013-07-21 16:20 UTC, Axel Krebs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Krebs 2013-07-21 15:05:46 UTC
opening a pic with image editor.

pic is jpg from NIKON D800

image editor show blackish areas as dark blue (=my setting)

these out-darkened areas show rectangular pattern in two cases:
1.) when applying correct color automatically _and_
2.) when opening this saved pic.

 

Reproducible: Always

Steps to Reproduce:
1. open image editor
2. open the jpg pics, created from NIKON D800
3. correct pics color setting automatically
4. use darklight with dark blue
5. watch the rectangular pattern. 

potential risk: colored areas my show pattern in viewing/improving software

Actual Results:  
the rectangular pattern (will attach a screenshot)

Expected Results:  
for given homogeneous colored original areas, I will _never_ see any type of pattern.
Comment 1 Axel Krebs 2013-07-21 15:07:40 UTC
Created attachment 81242 [details]
screenshot showing misleading pattern
Comment 2 Christoph Feck 2013-07-21 16:07:07 UTC
I do not see a misleading pattern, only camera noise.
Comment 3 Axel Krebs 2013-07-21 16:20:19 UTC
Created attachment 81244 [details]
suspected pattern with reddish underlied lines (vertical and horizontal)

the reddish marked lines- that's what I take for suspicious
Comment 4 Christoph Feck 2013-07-21 18:28:12 UTC
Check if they are 8 or 16 pixels apart. If they are, those are JPEG compression artifacts.
Comment 5 Axel Krebs 2013-07-21 19:37:21 UTC
Christoph,

looks like beeing 8 pixels apart.

How does it refer on _png_-format I sent to KDE bug-report system??
Does png do similar artefacts as jpg?


Axel

Am 21.07.2013 20:28, schrieb Christoph Feck:
> https://bugs.kde.org/show_bug.cgi?id=322656
> 
> --- Comment #4 from Christoph Feck <christoph@maxiom.de> ---
> Check if they are 8 or 16 pixels apart. If they are, those are JPEG compression
> artifacts.
>
Comment 6 Christoph Feck 2013-07-22 07:08:25 UTC
PNG is lossless, so the artifacts do not go away, if you convert from JPEG to PNG.
Comment 7 Axel Krebs 2013-07-22 07:35:28 UTC
Am 22.07.2013 09:08, schrieb Christoph Feck:
> https://bugs.kde.org/show_bug.cgi?id=322656
> 
> --- Comment #6 from Christoph Feck <christoph@maxiom.de> ---
> PNG is lossless, so the artifacts do not go away, if you convert from JPEG to
> PNG.
> 
so: artefacts are no bug, but a feature of jpg?
Comment 8 Christoph Feck 2013-07-22 11:37:44 UTC
Yes, JPEG compresses 8x8 blocks independently. You can see it extremely when using very low quality values.

Anyway, this is no bug. If you want no artifacts, your complete workflow must avoid JPEG compression.

For more information, please ask in a forum.