Bug 322602 - Feeds do not update although I'm online
Summary: Feeds do not update although I'm online
Status: RESOLVED WORKSFORME
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 5.3.0
Platform: Other Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-20 09:11 UTC by Philipp Hagemeister
Modified: 2021-04-16 04:33 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hagemeister 2013-07-20 09:11:19 UTC
When I click "Fetch All New Feeds", feeds do not update and the status bar says "Networking is not available.", although I have unlimited IPv4 and IPv6 connectivity, and DNS resolution works fine (I can browse the web with Konqueror, for example). This is on debian unstable. Routing tables look fine to me:

$ ip -4 r
default via 192.168.3.1 dev wlan0 
192.168.3.0/24 dev wlan0  proto kernel  scope link  src 192.168.3.11 
$ ip -6 r
2001:4dd0:ff00:336::/64 dev sixxs  proto kernel  metric 256 
fe80::/64 dev wlan0  proto kernel  metric 256 
fe80::/64 dev sixxs  proto kernel  metric 256 
default via 2001:4dd0:ff00:336::1 dev sixxs  metric 1024 
$ dig +short kde.org ANY
2a01:4f8:140:8302::3
46.4.96.250

Reproducible: Always

Steps to Reproduce:
1. Click "Fetch All Feeds"

Actual Results:  
Error icon for all feeds, status bar says "Networking is not available". No network traffic observed.

Expected Results:  
Updating of feeds.
Comment 1 Mathieu Roy 2014-02-17 13:51:25 UTC
Same here with version 4.11.5 shipped by Debian.
Comment 2 Mathieu Roy 2014-02-17 13:54:04 UTC
 And the workaround 

qdbus org.kde.kded /modules/networkstatus setNetworkStatus SolidNetwork 4

does not work for me.
Comment 3 Philipp Hagemeister 2014-02-17 14:05:45 UTC
Matthieu: Try

qdbus org.kde.kded /modules/networkstatus setNetworkStatus ntrack 4

or, instead of ntrack, whatever is last in the list emitted by

qdbus org.kde.kded /modules/networkstatus networks
Comment 4 Mathieu Roy 2014-02-17 14:11:50 UTC
Hi Philipp, 

I do have ntrack in networks. This new command works me 
qdbus org.kde.kded /modules/networkstatus setNetworkStatus ntrack 4

(I actually went already for the long version provided in https://bugs.archlinux.org/task/28850 )

Thanks!
Comment 5 Denis Kurz 2016-09-24 19:45:22 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of akregator (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 6 emilianh 2016-10-12 11:39:40 UTC
Yes, this bug still happens here with akregator/kontact/kmail 5.3.0, frameworks 5.27.0, qt 5.7.0
I don't have any network "manager" present as i don't need any. (nm, wicd, etc )

Maybe there should be an "assume always online" option that bypasses these "smart" checks.
Comment 7 Denis Kurz 2016-11-03 14:52:27 UTC
Thanks for the reply, setting to confirmed
Comment 8 Justin Zobel 2021-03-17 01:45:40 UTC
I've not noticed this on Akregator version 5.16.3 (20.12.3).

Are you able to please check and confirm if this issue is still occurring?

I've set this bug to NEEDSINFO. When you reply, please change the bug back to REPORTED so we know it's ready for investigation or RESOLVED/WORKSFORME if the issue is now resolved.
Comment 9 Bug Janitor Service 2021-04-01 04:33:32 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 10 Bug Janitor Service 2021-04-16 04:33:22 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!