Bug 322571 - Chat window doesn't have focus in new message text area
Summary: Chat window doesn't have focus in new message text area
Status: RESOLVED DUPLICATE of bug 310442
Alias: None
Product: telepathy
Classification: Unclassified
Component: text-ui (show other bugs)
Version: 0.6.2
Platform: openSUSE RPMs Linux
: NOR minor
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-19 13:19 UTC by Ruchir Brahmbhatt
Modified: 2013-11-13 10:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruchir Brahmbhatt 2013-07-19 13:19:22 UTC
When we open any account from contact list for chat, the new chat window doesn't have cursor focused in text area. 

Reproducible: Sometimes

Steps to Reproduce:
1. Open contact list.
2. Double click any contact to open chat window.

Actual Results:  
Cursor not focused in text area

Expected Results:  
Cursor should be in text area so after opening new chat window, we can directly start typing instead of doing additional step to move cursor in text area by clicking it.

It doesn't happen every time and when system starts, it happens during the day when I have switched between apps, suspended and resumed, and performed several actions.
Comment 1 Daniele E. Domenichelli 2013-07-19 23:30:07 UTC
I cannot reproduce this...
Comment 2 Ruchir Brahmbhatt 2013-07-20 05:33:15 UTC
It is not simple to reproduce as I mentioned in bug report. I am not sure about exact clear steps but surely I face this issue often during the day.
Comment 3 Daniele E. Domenichelli 2013-07-20 22:08:48 UTC
Are you sure that when this happens the text ui is the currently selected window? You should be able to see it by observing the window decoration. It could be the window manager stealing the focus from your window... If that's the case we cannot do anything about, I think
Comment 4 David Edmundson 2013-07-20 22:12:56 UTC
Do you think this is the same as https://bugs.kde.org/show_bug.cgi?id=310442 ?
Comment 5 Ruchir Brahmbhatt 2013-07-21 07:27:43 UTC
It is somewhat different. In that case window is being closed and in my case it is opened. I'm able to reproduce both bugs though. But not 100% of the time.
Comment 6 Ruchir Brahmbhatt 2013-07-26 13:19:24 UTC
I just reproduced this issue many times today. I close laptop lid and it goes to sleep. When it resumes, if I click new message icon in systray to read newly arrived message or I doubleclick contact in contact list to start new message, message text area doesn't have focus.
Comment 7 David Edmundson 2013-11-13 10:04:10 UTC

*** This bug has been marked as a duplicate of bug 310442 ***