Bug 322557 - Export to Rajce.net crashes when pressing close
Summary: Export to Rajce.net crashes when pressing close
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-WebService-Rajce (show other bugs)
Version: 3.3.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-07-19 08:17 UTC by Veaceslav Munteanu
Modified: 2021-08-26 16:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.4.0


Attachments
New crash information added by DrKonqi (7.63 KB, text/plain)
2013-08-15 07:24 UTC, Jiri Slaby
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Veaceslav Munteanu 2013-07-19 08:17:33 UTC
Application: digikam (3.3.0-beta3)
KDE Platform Version: 4.10.5 (Compiled from sources)
Qt Version: 4.8.5
Operating System: Linux 3.9.9-1-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:
 
I was working on digikam's tag tree and tried to test how export functions work so I tried:

1. Right click on tag
2. Export -> export to Rajce.net
3. Press close
4. Crash

p.s. digikam compiled from source, latest git snaphot.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f49c510e980 (LWP 8957))]

Thread 9 (Thread 0x7f4998ceb700 (LWP 8958)):
#0  0x00007f49b96a98b4 in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f49b9935266 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00000000005fdcf3 in Digikam::ScanController::run (this=0x233dde0) at /media/LinuxHDD/slavik/digikam-software-compilation/core/digikam/database/scancontroller.cpp:713
#3  0x00007f49b9934d8f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f49b96a5dd2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f49b8418cdd in clone () from /usr/lib/libc.so.6

Thread 8 (Thread 0x7f4993fff700 (LWP 8959)):
#0  0x00007f49b841008d in poll () from /usr/lib/libc.so.6
#1  0x00007f49b309d094 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f49b309d19c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f49b9a61ba6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x00007f49b9a33b5f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x00007f49b9a33e55 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00007f49b99326ef in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x00007f49b9a15303 in ?? () from /usr/lib/libQtCore.so.4
#8  0x00007f49b9934d8f in ?? () from /usr/lib/libQtCore.so.4
#9  0x00007f49b96a5dd2 in start_thread () from /usr/lib/libpthread.so.0
#10 0x00007f49b8418cdd in clone () from /usr/lib/libc.so.6

Thread 7 (Thread 0x7f49937fe700 (LWP 8961)):
#0  0x00007f49b96a98b4 in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f49b9935266 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f49c1af2f3d in Digikam::ParkingThread::run (this=0x25f22e0) at /media/LinuxHDD/slavik/digikam-software-compilation/core/libs/threads/threadmanager.cpp:119
#3  0x00007f49b9934d8f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f49b96a5dd2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f49b8418cdd in clone () from /usr/lib/libc.so.6

Thread 6 (Thread 0x7f495ffff700 (LWP 9288)):
#0  0x00007f49b96a98b4 in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f49b9935266 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f495c1ab79a in KIPIPlugins::KPRawThumbThread::run (this=0x23860e0) at /media/LinuxHDD/slavik/digikam-software-compilation/extra/kipi-plugins/common/libkipiplugins/tools/kprawthumbthread.cpp:108
#3  0x00007f49b9934d8f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f49b96a5dd2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f49b8418cdd in clone () from /usr/lib/libc.so.6

Thread 5 (Thread 0x7f495d7fa700 (LWP 9289)):
#0  0x00007f49b96a9c61 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f49b9935244 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f49b9928945 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f49b9934d8f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f49b96a5dd2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f49b8418cdd in clone () from /usr/lib/libc.so.6

Thread 4 (Thread 0x7f497dc38700 (LWP 9290)):
#0  0x00007f49b88ffb12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f49b88fe37e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f49b96a5dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f49b8418cdd in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f495dffb700 (LWP 9291)):
#0  0x00007f49b88ffb12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f49b88fe37e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f49b96a5dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f49b8418cdd in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f497fc3c700 (LWP 9292)):
#0  0x00007f49b88ffb12 in ?? () from /usr/lib/libgomp.so.1
#1  0x00007f49b88fe37e in ?? () from /usr/lib/libgomp.so.1
#2  0x00007f49b96a5dd2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f49b8418cdd in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f49c510e980 (LWP 8957)):
[KCrash Handler]
#5  0x00007f49b99ad420 in QDir::fromNativeSeparators(QString const&) () from /usr/lib/libQtCore.so.4
#6  0x00007f49b99eff6c in QUrl::fromLocalFile(QString const&) () from /usr/lib/libQtCore.so.4
#7  0x00007f4925b89f90 in KIPIRajceExportPlugin::RajceWidget::cancelUpload (this=0x476ddb0) at /media/LinuxHDD/slavik/digikam-software-compilation/extra/kipi-plugins/rajceexport/rajcewidget.cpp:540
#8  0x00007f4925b8d324 in KIPIRajceExportPlugin::RajceWindow::slotClose (this=0x5c979a0) at /media/LinuxHDD/slavik/digikam-software-compilation/extra/kipi-plugins/rajceexport/rajcewindow.cpp:104
#9  0x00007f4925b8cb3e in KIPIRajceExportPlugin::RajceWindow::qt_static_metacall (_o=0x5c979a0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fff735e1b60) at /media/LinuxHDD/slavik/digikam-software-compilation/build/extra/kipi-plugins/rajceexport/rajcewindow.moc:52
#10 0x00007f49b9a48ba8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#11 0x00007f49bb30e370 in KDialog::slotButtonClicked(int) () from /usr/lib/libkdeui.so.5
#12 0x00007f49bb30fb5f in ?? () from /usr/lib/libkdeui.so.5
#13 0x00007f49b9a48ba8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#14 0x00007f49b9a502fe in QSignalMapper::mapped(int) () from /usr/lib/libQtCore.so.4
#15 0x00007f49b9a50406 in QSignalMapper::map(QObject*) () from /usr/lib/libQtCore.so.4
#16 0x00007f49b9a48ba8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#17 0x00007f49bacd3e72 in QAbstractButton::clicked(bool) () from /usr/lib/libQtGui.so.4
#18 0x00007f49baa38523 in ?? () from /usr/lib/libQtGui.so.4
#19 0x00007f49baa39693 in ?? () from /usr/lib/libQtGui.so.4
#20 0x00007f49baa3977c in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#21 0x00007f49ba6da6de in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#22 0x00007f49ba68b12c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#23 0x00007f49ba69182d in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#24 0x00007f49bb3abf5a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#25 0x00007f49b9a34efd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#26 0x00007f49ba690fe3 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#27 0x00007f49ba702c5b in ?? () from /usr/lib/libQtGui.so.4
#28 0x00007f49ba7016cc in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#29 0x00007f49ba728232 in ?? () from /usr/lib/libQtGui.so.4
#30 0x00007f49b309cda6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0x00007f49b309d0f8 in ?? () from /usr/lib/libglib-2.0.so.0
#32 0x00007f49b309d19c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0x00007f49b9a61b85 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#34 0x00007f49ba7282e6 in ?? () from /usr/lib/libQtGui.so.4
#35 0x00007f49b9a33b5f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0x00007f49b9a33e55 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#37 0x00007f49b9a38f8b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#38 0x0000000000713ef4 in main (argc=1, argv=0x7fff735e3398) at /media/LinuxHDD/slavik/digikam-software-compilation/core/digikam/main/main.cpp:235

Possible duplicates by query: bug 312540.

Reported using DrKonqi
Comment 1 Jiri Slaby 2013-08-15 07:24:22 UTC
Created attachment 81717 [details]
New crash information added by DrKonqi

gwenview (4.10.4) on KDE Platform 4.10.5 "release 1" using Qt 4.8.4

- What I was doing when the application crashed:

It suffices to go via export and press cancel.

-- Backtrace (Reduced):
#6  QString (other=..., this=0x7fff2feb7bf0) at ../../src/corelib/tools/qstring.h:725
#7  QDir::fromNativeSeparators (pathName=...) at io/qdir.cpp:854
#8  0x00007f67859fce07 in QUrl::fromLocalFile (localFile=...) at io/qurl.cpp:6257
#9  0x00007f6756de20f5 in KIPIRajceExportPlugin::RajceWidget::cancelUpload (this=0x17bca30) at /usr/src/debug/digikam-3.2.0/extra/kipi-plugins/rajceexport/rajcewidget.cpp:540
#10 0x00007f6756de658d in KIPIRajceExportPlugin::RajceWindow::slotClose (this=0x1769930) at /usr/src/debug/digikam-3.2.0/extra/kipi-plugins/rajceexport/rajcewindow.cpp:104
Comment 2 Jiri Slaby 2013-08-15 07:34:14 UTC
This a dup of bug 307689
Comment 3 caulier.gilles 2013-08-15 08:48:14 UTC

*** This bug has been marked as a duplicate of bug 307689 ***
Comment 4 caulier.gilles 2021-08-26 16:56:05 UTC
Fixed with #307689