Bug 322515 - Option to hide the scrollbars in Krita "normal mode", just like in canvas only mode
Summary: Option to hide the scrollbars in Krita "normal mode", just like in canvas onl...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Usability (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-18 07:39 UTC by ALeXeY
Modified: 2014-05-30 15:44 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ALeXeY 2013-07-18 07:39:37 UTC
It would be useful to have an option(s) for hide the scrollbars (and may be other UI elements, status bar etc) in Krita "normal mode" like the similar options, existing now in canvas only mode.

Reproducible: Always
Comment 1 Halla Rempt 2013-07-20 11:59:17 UTC
Ack, thanks!
Comment 2 federico.fieni 2013-11-16 16:10:22 UTC
It is possible to get this functionality right now by selecting "canvas only" mode and then switching off "full screen" by pressing the default combination Ctrl + Shift + F.
However I think it would be better not to set the window to fullscreen by default when selecting "canvas only" mode.
In my case this would be especially useful because I like to use a clean "New View" as a "thumbnail view" to keep an eye on while working on smaller portions of an image. (This technique is used by many illustrators and using a "New View" is better and more versatile than using the "Overview" docker because you can zoom, edit etc.).
Comment 3 Odysseas 2013-11-21 13:50:49 UTC
I also find this a very useful feature. It is essential to have the option to set an interface with the least distractions possible. 
So, features like the status bar and the scrollbars would be of secondary importance.

Why not simply add the option to hide the scrollbars, in the same way we can hide the status bar?

Very useful will be an interface configuration similar to that of Gimp, where the user can choose to permanently hide features like these.
Comment 4 Halla Rempt 2014-04-01 08:23:04 UTC
Git commit adeefb6c99dc420a9cc4600b82016fa33aad471b by Boudewijn Rempt.
Committed on 01/04/2014 at 09:13.
Pushed by rempt into branch 'master'.

Patch by Ghevan. Thanks!
CCMAIL:ghevan@gmail.com

M  +3    -0    krita/ui/dialogs/kis_dlg_preferences.cc
M  +11   -1    krita/ui/forms/wdgdisplaysettings.ui
M  +10   -0    krita/ui/kis_config.cc
M  +3    -0    krita/ui/kis_config.h
M  +21   -12   krita/ui/kis_view2.cpp
M  +1    -0    krita/ui/kis_view2.h

http://commits.kde.org/calligra/adeefb6c99dc420a9cc4600b82016fa33aad471b
Comment 5 Halla Rempt 2014-05-30 15:44:00 UTC
Git commit 10a4ab49fb5f2d56bcee1af59dfe194007719d6f by Boudewijn Rempt.
Committed on 01/04/2014 at 09:13.
Pushed by dickson into tag 'steam-247500_247566'.

Patch by Ghevan. Thanks!
CCMAIL:ghevan@gmail.com

M  +3    -0    krita/ui/dialogs/kis_dlg_preferences.cc
M  +11   -1    krita/ui/forms/wdgdisplaysettings.ui
M  +10   -0    krita/ui/kis_config.cc
M  +3    -0    krita/ui/kis_config.h
M  +21   -12   krita/ui/kis_view2.cpp
M  +1    -0    krita/ui/kis_view2.h

http://commits.kde.org/calligra/10a4ab49fb5f2d56bcee1af59dfe194007719d6f