Bug 322397 - "Bouncy" busy cursor: desaturated app icon when moving cursor
Summary: "Bouncy" busy cursor: desaturated app icon when moving cursor
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-various (show other bugs)
Version: 4.10.95
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-15 16:08 UTC by rockonthemoonfm
Modified: 2013-08-19 23:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rockonthemoonfm 2013-07-15 16:08:22 UTC
busy app icon defaults to "Bouncing cursor". It represents a happy way to notify the user if an app has been launched and which. Currently systemsettings offers other 2 cursors animations,  "Passive" and "Blinking", and the latter is broken when compositing is turned on.

"Passive busy cursor" produces a still app icon beside cursor as app launch feedback, and this is misleading. In modern UIs where everything is gracefully animated, it feels more "natural" (even rocks in nature remain never the same) to have animations, and feels extraneous and broken something that is still.

So maybe better that having 3 ways or doing busy cursors, whose two aren't working for different causes, it's better to leave the user the choice between the default "Bouncing" animation, and no busy effect. Notification kcm should reflect the change with a checkbox instead of the dropdown button.

More, there is an ambiguity in systemsettings: while you can configure and turn off busy cursors in Notifications kcm, in Desktop Effects kcm you can turn off the effect too. I don't think it's a good idea to control one whole thing in a place (the proper one), and a part of it in another. That is to say, probably it's better to cancel the "Candy: Startup Feedback" entry in kwin kcm and leave the effect active for user using compositing.
The very same reasoning could be applied for other effects too, like "Highlight windows" (Alt-Tab effect can use it).


Reproducible: Always

Steps to Reproduce:
1. System settings > Launch Feedback > Busy Cursor,  select "Passive busy cursor" or "Blinking cursor"

Actual Results:  
still, not animated, busy app icon if compositing is on.

Expected Results:  
always animated busy app icon, if ON.
Comment 1 Thomas Lübking 2013-07-15 18:49:41 UTC
Passive cursor bug (leaving traces) is bug #260727
OP suggests to drop all but bouncing and make startup feedback a toggle.

IIRC Fredrik had once mentioned to have a completely different replacement for the startup feedback mechanism (no mouse cursor icon shape stuff)

@Joseph
The entry in the effect lists exists, because it lists *all* effects and the effect only overtakes painting whe using GL compositing (because those littly things create a pretty huge overhead in that case)
It has no direct impact on whether startup feedback is used or not.

There's a bug about the effect configuration being to complex (and the idea was to completely dissamble it, have effects align to some regular settings and only allow direct manipulation of effect loading through a dedicated dialog)

Reg. the idea to reduce startup feedback mechanisms:
a) that's actually not a KWin topic ("you're on the wrong product")
b) this is likely best discussed at the KDE brainstorm forum [1] - at least the KWin maintainer/developers are unlikely in position to decide such on their own.

[1] http://forum.kde.org/viewforum.php?f=83&sid=7289578934bf723c26e844bcb165ce6a
Comment 2 rockonthemoonfm 2013-07-21 13:42:11 UTC
I changed the target of my bug report to something humbler, so opened it again.
Surprisingly, the whole thing changed after upgrading from 4.10.90 to 4.10.95.
1. Passive effect started to show same bug tracked in https://bugs.kde.org/show_bug.cgi?id=260727
2. Blinking effect works again (even if it's ugly:)
3. Bouncy effect now desaturates when moving cursor. This happens only when OpenGL 2.0 or 3.1 is selected. Works in 1.2 mode. VSync doesn't change things.
Comment 3 Thomas Lübking 2013-07-21 13:59:14 UTC
please attach the output of "qdbus org.kde.kwin /KWin supportInformation"
Comment 4 rockonthemoonfm 2013-07-21 15:46:02 UTC
http://paste.kde.org/p9c56c71b/
Comment 5 Thomas Lübking 2013-07-21 19:31:00 UTC
(In reply to comment #2)

> 3. Bouncy effect now desaturates when moving cursor. This happens only when
> OpenGL 2.0 or 3.1 is selected. Works in 1.2 mode. VSync doesn't change
> things.

Dirty shader state, but color correction is disabled.

- Does it "desaturate" slowely or instanly?
- Does it matter where you move it?
- Does it really "desaturate" or rather "darken" or "get translucent"?
- Does it happen when deactivating either
   * blurring
   * translucency
   * dialogparent
   * fade
(and restart the compositor afterwards, ie. press "Shift+Alt+F12" twice)
- Can you record a video / make one or two screenshot(s)?
Comment 6 rockonthemoonfm 2013-07-21 21:06:34 UTC
> Dirty shader state, but color correction is disabled.
> 
> - Does it "desaturate" slowely or instanly?
instantly
> - Does it matter where you move it?
no
> - Does it really "desaturate" or rather "darken" or "get translucent"?
desaturate, as far as i can see
> - Does it happen when deactivating either
>    * blurring
>    * translucency
>    * dialogparent
>    * fade
> (and restart the compositor afterwards, ie. press "Shift+Alt+F12" twice)
yes
> - Can you record a video / make one or two screenshot(s)?
https://www.dropbox.com/s/gbnssdljf4wbfd3/desktop_video.mp4
Comment 7 Thomas Lübking 2013-07-22 11:57:31 UTC
(In reply to comment #6)
> > - Can you record a video / make one or two screenshot(s)?
> https://www.dropbox.com/s/gbnssdljf4wbfd3/desktop_video.mp4

Could this be the diabled icon look (or whatever causes the desaturated & translucent icon on the taskbar)
Comment 8 rockonthemoonfm 2013-07-22 13:21:50 UTC
no, it happens on every launcher, e.g. kickoff too.
Comment 9 Thomas Lübking 2013-07-22 13:53:17 UTC
Yes, no.
I meant the effect you can configure in "kcmshell4 icons" / "Advanced" tab
Comment 10 rockonthemoonfm 2013-07-22 14:31:24 UTC
> Could this be the diabled icon look (or whatever causes the desaturated &
> translucent icon on the taskbar)

ok, got it. No, doesn't change anything.

But i've just found something funny. I was noticing that bouncy cursor sometimes is working as expected: when? When non-qt windows have focus, it works. When a qt window is on top (not necessarily active), is see the bug. 
Tricky
Comment 11 Thomas Lübking 2013-07-22 17:17:21 UTC
Any impact of either GUI style ("kwrite --style plastique") or window opacity?
Comment 12 rockonthemoonfm 2013-07-22 18:38:55 UTC
> Any impact of either GUI style ("kwrite --style plastique") or window
> opacity?
nope

should change title like 
"Bouncy" busy cursor: desaturated app icon when moving cursor and qt app has focus"
Comment 13 rockonthemoonfm 2013-08-19 23:06:34 UTC
don't ask me why, but in 4.11 final it just works :)
simply great release guys, you rock!