Bug 322360 - Camera found as PTP Device, but if importing Images abort with "connection error"
Summary: Camera found as PTP Device, but if importing Images abort with "connection er...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Gphoto2 (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-14 18:31 UTC by Samuel Suther
Modified: 2017-08-15 22:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Suther 2013-07-14 18:31:48 UTC
The cam is displayed as Nikon D70 PTP-Mode, if i plugin the cam.

If i go to import-Dialoge, to fetch images, I got an "Connection Error" after 30 Seconds.

Digikam 2.5.0 on Ubuntu Precise (12.04)

Reproducible: Always
Comment 1 caulier.gilles 2013-07-15 07:24:00 UTC
The most important part is libgphoto2 used by digiKam. All PTP driver are in this lib.

I remember and old similar report about this problem. This have been fixed to update libgphoto2 and digiKam. You DK version is 2.5.0 which is pretty old. last 2.x release is 2.9.0. Last stable is 3.2.0.

Gilles Caulier
Comment 2 Samuel Suther 2013-07-16 06:02:39 UTC
It's the Ubuntu 12.04 LTS Version. This digikam Version is default there.
libgphoto is 2.4.13
Comment 3 Teemu Rytilahti 2013-12-02 15:10:21 UTC
Could you test if this is valid with newer digikam and libgphoto2? If not installing to your regular system, then inside a virtual machine?
Comment 4 Samuel Suther 2013-12-05 09:40:09 UTC
digiKam
Version 3.4.0
Unter KDE 4.11.2

Work now. Ticket can be closed