Bug 322206 - Kwin crashes when using gwenview in full screen mode
Summary: Kwin crashes when using gwenview in full screen mode
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: core (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-10 17:03 UTC by noquieroregistrarme
Modified: 2013-07-19 20:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description noquieroregistrarme 2013-07-10 17:03:05 UTC
KDE 4.8.4, Debian Wheezy.

When I set gwenview to show full screen mode, after some time, when passing images with the space bar, kwin crashes, and then restarts. Apparently no harm done, but it is annoying.

Didn't test whether using another method of passing from one picture to another besides space bar triggers the crash.

Reproducible: Sometimes

Steps to Reproduce:
1. Start KDE
2. Open gwenview
3. Set it to display pictures in full screen mode
4. Pass the pictures with space bar.
Actual Results:  
Frequently, kwin crashes, and restarts.

Expected Results:  
Do not crash.
Comment 1 noquieroregistrarme 2013-07-10 17:05:32 UTC
Might be related to thumbnail generation.
Comment 2 Thomas Lübking 2013-07-10 17:54:31 UTC
no, it's most likely bug #252817 - you'll have to provide a backtrace (dr. konqui, "developer information") to get ensured about it.

Without a backtrace there is absolutely nothing we could say or do about this, so please provide it (just post it into the bug)
Comment 3 noquieroregistrarme 2013-07-11 12:55:39 UTC
It happened again, I was passing the pictures by deleting them (with Del key), then the entire screen went gray. Pressing ESC to exit full screen mode worked, but Kwin crashed.

Follows backtrace. Regards.

------------------------------------------------------------------------------------------------------

Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6a0ec0a780 (LWP 7496))]

Thread 2 (Thread 0x7f69eb9c9700 (LWP 7571)):
#0  0x00007f6a032132d4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f6a0b068e77 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f6a0b068ea9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f6a0320eb50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4  0x00007f6a0e5aea7d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6a0ec0a780 (LWP 7496)):
[KCrash Handler]
#5  0x00007f69f2952bbc in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#6  0x00007f69f2952750 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#7  0x00007f69f293ca90 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#8  0x00007f69f292a527 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#9  0x00007f69f2a49453 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#10 0x00007f6a0aa8f717 in ?? () from /usr/lib/libkwinglutils.so.1
#11 0x00007f6a0aa8f815 in KWin::GLVertexBuffer::render(QRegion const&, unsigned int) () from /usr/lib/libkwinglutils.so.1
#12 0x00007f6a0e9181f0 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#13 0x00007f6a0e91eb28 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#14 0x00007f6a0e909c8e in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#15 0x00007f6a0e929385 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#16 0x00007f6a0e908d06 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#17 0x00007f6a0e929685 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#18 0x00007f6a0e9096eb in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#19 0x00007f6a0e90a589 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#20 0x00007f6a0e908c34 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#21 0x00007f6a0e929203 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#22 0x00007f6a0e90b828 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#23 0x00007f6a0e91f64d in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#24 0x00007f6a0e905ac1 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#25 0x00007f6a09d8685c in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#26 0x00007f6a0911b70c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#27 0x00007f6a0911fb8a in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#28 0x00007f6a0e0b0886 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#29 0x00007f6a09d71b5e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#30 0x00007f6a09da2a52 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#31 0x00007f6a09da2c08 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#32 0x00007f6a091bd5df in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#33 0x00007f6a09d708af in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#34 0x00007f6a09d70b38 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#35 0x00007f6a09d75cf8 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#36 0x00007f6a0e8c023e in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#37 0x00007f6a0e4f2ead in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#38 0x0000000000400771 in _start ()
Comment 4 Thomas Lübking 2013-07-11 13:01:41 UTC
Disable "suspend compositing for fullscreen windows" (assuming it's enabled...) and the crash will likely be gone (unfortunately the backtrace does not contain debug symbols but the odds it is bug #252817 are extremely high)

If "suspend compositing for fullscreen windows" is not enabled or disabling it does not "fix" it, please re-open the bug.

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 5 noquieroregistrarme 2013-07-19 20:05:46 UTC
(In reply to comment #4)
> Disable "suspend compositing for fullscreen windows" (assuming it's
> enabled...) and the crash will likely be gone (unfortunately the backtrace
> does not contain debug symbols but the odds it is bug #252817 are extremely
> high)

This solution worked for me. Thanks.