Bug 322072 - Launcher looks the same as minimized applications
Summary: Launcher looks the same as minimized applications
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: 4.10.90
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-07 16:22 UTC by Mark
Modified: 2013-07-27 17:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2013-07-07 16:22:06 UTC
Hi,

KDE 4.11 apparently seems to be getting the new QML post of the tasks applet. However, there is no more clear default distinction between launchers and minimized applications.

Reproducible: Always

Steps to Reproduce:
Install KDE 4.11 (beta 1 or 2)
Actual Results:  
Launchers look exactly the same as minimized applications.

Expected Results:  
Launchers used to show just the icon, nothing more.
Open applications show the icon and the app title.
Comment 1 Eike Hein 2013-07-07 17:48:41 UTC

*** This bug has been marked as a duplicate of bug 321128 ***
Comment 2 Eike Hein 2013-07-27 17:11:29 UTC
Git commit f21aaf0b375279a3bc00de696e70449452ef082d by Eike Hein.
Committed on 27/07/2013 at 17:05.
Pushed by hein into branch 'KDE/4.11'.

Proper appearance and geometry for launcher items.

Unlike in the old applet, this has launcher items interact
reasonably with multi-row configurations.

Also optimizes the layout code a bit, avoiding needless
update churn.

M  +13   -1    libs/taskmanager/tasksmodel.cpp
M  +56   -10   plasma/desktop/applets/tasks/package/contents/code/layout.js
M  +16   -4    plasma/desktop/applets/tasks/package/contents/ui/Task.qml
M  +10   -1    plasma/desktop/applets/tasks/package/contents/ui/main.qml

http://commits.kde.org/kde-workspace/f21aaf0b375279a3bc00de696e70449452ef082d