Bug 321959 - kwin crashes after exiting opengl animated slideshow in gwenview when "suspend desktop effects for fullscreen windows" is enabled
Summary: kwin crashes after exiting opengl animated slideshow in gwenview when "suspen...
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: 4.10.90
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-04 18:33 UTC by rockonthemoonfm
Modified: 2013-07-04 18:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
gdb report (3.26 KB, text/plain)
2013-07-04 18:33 UTC, rockonthemoonfm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rockonthemoonfm 2013-07-04 18:33:08 UTC
kwin always crashes after exiting opengl animated slideshow in gwenview when "suspend desktop effects for fullscreen windows" is enabled.
Gwenview opengl animations looks buggy..
Attached gdb info.

Reproducible: Always

Steps to Reproduce:
1. enable "Suspend desktop effects for fullscreen windows" in kwin kcm
2. open gwenview, select "Animations: openGL" in "Settings > Configure"
3. start a photo Slideshow, then exit [esc]

Actual Results:  
kwin crashes.

Expected Results:  
kwin doesn't crash.
Comment 1 rockonthemoonfm 2013-07-04 18:33:45 UTC
Created attachment 80948 [details]
gdb report
Comment 2 Thomas Lübking 2013-07-04 18:55:33 UTC
Despite the backtrace actually lacks the relevant info, it's a dupe of the most famous kwin bug (or rather mesa, eventually intel) bug ever.
The driver has issues with several GL contexts and unredirection....

> enable "Suspend desktop effects for fullscreen windows" in kwin kcm
... and that's ultimately why this off by default.

-> For clients that matter (games), use composite blocking, otherwise just keep the window redirected along all others.

We had several considerations to dump unredirection.

*** This bug has been marked as a duplicate of bug 252817 ***