Bug 321933 - mouse pointer with red-eye reduction
Summary: mouse pointer with red-eye reduction
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.4
Platform: Slackware Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2013-07-04 07:17 UTC by jean.ribiere
Modified: 2018-07-26 18:36 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 18.08.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jean.ribiere 2013-07-04 07:17:10 UTC
When I start gwenview, the mouse pointer is an arrow-pointer.

If I move the mouse on the area containing the photo, the mouse pointer is a hand-pointer.
The problem is a hand pointer is not very precise to do a correction.
In a old version, the mouse pointer did not change.

Is it possible to leave the arrow pointer for red-eye redcution ?
 

Reproducible: Always

Steps to Reproduce:
1. as described before
2.
3.
Comment 1 Nate Graham 2017-09-09 21:14:43 UTC
Confirmed. Might be an easy fix. Let's see if I can work up a patch.
Comment 2 Nate Graham 2017-09-09 21:32:21 UTC
Clearly a bug, since the code *tries* to set an appropriate cursor:

void RedEyeReductionTool::toolActivated()
{
    imageView()->setCursor(Qt::CrossCursor);
}


Looks like whatever part sets the hand cursor is always overriding this.
Comment 3 Nate Graham 2017-09-09 22:28:54 UTC
It looks like this affects other tools, too.
Comment 4 null 2018-07-26 18:36:39 UTC
Git commit e97eda1df871cebc87834822a08c5f34fc80938b by Henrik Fehlauer.
Committed on 26/07/2018 at 18:36.
Pushed by rkflx into branch 'Applications/18.08'.

Fix crosshair cursor not showing in red eye reduction tool

Summary:
`RedEyeReductionTool::toolActivated` sets `Qt::CrossCursor` to allow for
more precise positioning where to apply the red eye reduction.

Due to `RasterImageView::setCurrentTool` calling `updateCursor`
afterwards, that change is immediately overridden again, though.

By moving around the latter, the issue can be fixed.
FIXED-IN: 18.08.0

Test Plan:
In {nav View} mode, activate the {nav Red Eye Reduction} tool. A
crosshair cursor should show, and hide again upon closing the tool.

Reviewers: #gwenview, ngraham

Reviewed By: #gwenview, ngraham

Subscribers: muhlenpfordt, ngraham

Differential Revision: https://phabricator.kde.org/D14386

M  +5    -1    lib/documentview/rasterimageview.cpp

https://commits.kde.org/gwenview/e97eda1df871cebc87834822a08c5f34fc80938b