Bug 321904 - Opening Photo Management Program crash
Summary: Opening Photo Management Program crash
Status: RESOLVED UPSTREAM
Alias: None
Product: Phonon
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-03 14:17 UTC by Mike L
Modified: 2013-08-05 15:17 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike L 2013-07-03 14:17:31 UTC
Application: digikam (3.2.0)
KDE Platform Version: 4.10.4
Qt Version: 4.8.4
Operating System: Linux 3.10.0-rc4-1-desktop x86_64
Distribution: "openSUSE 13.1 Milestone 2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Opening Photo Management Program for the first time.   App crashed towards end of setup wizard.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe36c011800 (LWP 3066))]

Thread 4 (Thread 0x7fe34b589700 (LWP 3067)):
#0  0x00007fe36371e964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe36724161b in wait (time=18446744073709551615, this=0x1886480) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x16132f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005d9f48 in ?? ()
#4  0x00007fe3672410bc in QThreadPrivate::start (arg=0x1891370) at thread/qthread_unix.cpp:338
#5  0x00007fe36371ae0e in start_thread () from /lib64/libpthread.so.0
#6  0x00007fe3657acb9d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fe34ad88700 (LWP 3068)):
#0  0x00007fe36371ce25 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007fe35d4308f1 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe35d3f0b14 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe35d3f1015 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fe35d3f11a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007fe36736b196 in QEventDispatcherGlib::processEvents (this=0x147c560, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fe36733ba6f in QEventLoop::processEvents (this=this@entry=0x7fe34ad87d50, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fe36733bcf8 in QEventLoop::exec (this=0x7fe34ad87d50, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fe36723e8e0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#9  0x00007fe36731d5ff in QInotifyFileSystemWatcherEngine::run (this=0x14b7310) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00007fe3672410bc in QThreadPrivate::start (arg=0x14b7310) at thread/qthread_unix.cpp:338
#11 0x00007fe36371ae0e in start_thread () from /lib64/libpthread.so.0
#12 0x00007fe3657acb9d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fe34a587700 (LWP 3070)):
#0  0x00007fe36371e964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe36724161b in wait (time=18446744073709551615, this=0x1602520) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x179ae88, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fe369621079 in ?? () from /usr/lib64/libdigikamcore.so.3
#4  0x00007fe3672410bc in QThreadPrivate::start (arg=0x179ae70) at thread/qthread_unix.cpp:338
#5  0x00007fe36371ae0e in start_thread () from /lib64/libpthread.so.0
#6  0x00007fe3657acb9d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fe36c011800 (LWP 3066)):
[KCrash Handler]
#5  gst_audio_clock_new (name=name@entry=0x7fe34364946a "GstPulseSinkClock", func=func@entry=0x7fe34363abe0 <gst_pulsesink_get_time>, user_data=user_data@entry=0x1a9ac80, destroy_notify=0x2) at gstaudioclock.c:143
#6  0x00007fe34363a173 in gst_pulsesink_init (pulsesink=0x1a9ac80, klass=<optimized out>) at pulsesink.c:2220
#7  0x00007fe35caab19c in g_type_create_instance (type=<optimized out>) at gtype.c:1868
#8  0x00007fe35ca8ecb5 in g_object_new_internal (class=class@entry=0x1a85040, params=params@entry=0x7fff5a0eb330, n_params=n_params@entry=1) at gobject.c:1738
#9  0x00007fe35ca90c26 in g_object_new_valist (object_type=object_type@entry=27835120, first_property_name=first_property_name@entry=0x7fe359f43b82 "name", var_args=var_args@entry=0x7fff5a0eb488) at gobject.c:1994
#10 0x00007fe35ca911e4 in g_object_new (object_type=27835120, first_property_name=first_property_name@entry=0x7fe359f43b82 "name") at gobject.c:1551
#11 0x00007fe359ecc9d5 in gst_element_factory_create (factory=factory@entry=0x1a00120, name=name@entry=0x1a8de80 "autoaudiosink0-actual-sink-pulse") at gstelementfactory.c:385
#12 0x00007fe342fd9524 in gst_auto_audio_sink_create_element_with_pretty_name (factory=0x1a00120, sink=0x1a8f020) at gstautoaudiosink.c:230
#13 gst_auto_audio_sink_find_best (sink=0x1a8f020) at gstautoaudiosink.c:261
#14 gst_auto_audio_sink_detect (sink=0x1a8f020) at gstautoaudiosink.c:342
#15 gst_auto_audio_sink_change_state (element=0x1a8f020, transition=GST_STATE_CHANGE_NULL_TO_READY) at gstautoaudiosink.c:390
#16 0x00007fe359ecb91c in gst_element_change_state (element=element@entry=0x1a8f020, transition=transition@entry=GST_STATE_CHANGE_NULL_TO_READY) at gstelement.c:2761
#17 0x00007fe359ecc268 in gst_element_set_state_func (element=0x1a8f020, state=GST_STATE_READY) at gstelement.c:2717
#18 0x00007fe348500636 in Phonon::Gstreamer::DeviceManager::canOpenDevice (this=<optimized out>, element=0x1a8f020) at /usr/src/debug/phonon-backend-gstreamer-4.6.3/gstreamer/devicemanager.cpp:176
#19 0x00007fe34850083d in Phonon::Gstreamer::DeviceManager::createAudioSink (this=this@entry=0x199d740, category=category@entry=Phonon::NoCategory) at /usr/src/debug/phonon-backend-gstreamer-4.6.3/gstreamer/devicemanager.cpp:233
#20 0x00007fe3485009fa in Phonon::Gstreamer::DeviceManager::createAudioSink (this=this@entry=0x199d740, category=category@entry=Phonon::NoCategory) at /usr/src/debug/phonon-backend-gstreamer-4.6.3/gstreamer/devicemanager.cpp:267
#21 0x00007fe3485013ca in Phonon::Gstreamer::DeviceManager::updateDeviceList (this=this@entry=0x199d740) at /usr/src/debug/phonon-backend-gstreamer-4.6.3/gstreamer/devicemanager.cpp:417
#22 0x00007fe34850215e in Phonon::Gstreamer::DeviceManager::DeviceManager (this=0x199d740, backend=<optimized out>) at /usr/src/debug/phonon-backend-gstreamer-4.6.3/gstreamer/devicemanager.cpp:133
#23 0x00007fe3484fd762 in Phonon::Gstreamer::Backend::Backend (this=0x199d0e0, parent=<optimized out>) at /usr/src/debug/phonon-backend-gstreamer-4.6.3/gstreamer/backend.cpp:116
#24 0x00007fe3484fda73 in qt_plugin_instance () at /usr/src/debug/phonon-backend-gstreamer-4.6.3/gstreamer/backend.cpp:44
#25 0x00007fe3673216db in QPluginLoader::instance (this=0x7fff5a0ebdf0) at plugin/qpluginloader.cpp:204
#26 0x00007fe348a1834c in Phonon::KdePlatformPlugin::createBackend (this=this@entry=0x1998eb0, newService=...) at /usr/src/debug/kde-runtime-4.10.4/phonon/platform_kde/kdeplatformplugin.cpp:130
#27 0x00007fe348a18d0d in Phonon::KdePlatformPlugin::createBackend (this=0x1998eb0) at /usr/src/debug/kde-runtime-4.10.4/phonon/platform_kde/kdeplatformplugin.cpp:183
#28 0x00007fe36b781899 in Phonon::FactoryPrivate::createBackend (this=0x1997440) at /usr/src/debug/phonon-4.6.0/phonon/factory.cpp:130
#29 0x00007fe36b7820b7 in Phonon::Factory::backend (createWhenNull=192, createWhenNull@entry=true) at /usr/src/debug/phonon-4.6.0/phonon/factory.cpp:460
#30 0x00007fe36b782432 in Phonon::Factory::createAudioOutput (parent=0x199bb50) at /usr/src/debug/phonon-4.6.0/phonon/factory.cpp:356
#31 0x00007fe36b77b40e in createBackendObject (this=0x13a9410) at /usr/src/debug/phonon-4.6.0/phonon/audiooutput.cpp:138
#32 Phonon::AudioOutputPrivate::createBackendObject (this=0x13a9410) at /usr/src/debug/phonon-4.6.0/phonon/audiooutput.cpp:133
#33 0x00007fe36b778707 in Phonon::AudioOutputPrivate::init (this=0x13a9410, c=Phonon::VideoCategory) at /usr/src/debug/phonon-4.6.0/phonon/audiooutput.cpp:111
#34 0x00007fe36b7a42d3 in ensureCreated (this=0x1996660) at /usr/src/debug/phonon-4.6.0/phonon/videoplayer.cpp:67
#35 Phonon::VideoPlayerPrivate::ensureCreated (this=0x1996660) at /usr/src/debug/phonon-4.6.0/phonon/videoplayer.cpp:60
#36 0x00007fe36b7a44ed in Phonon::VideoPlayer::mediaObject (this=0x1993c90) at /usr/src/debug/phonon-4.6.0/phonon/videoplayer.cpp:102
#37 0x0000000000665deb in ?? ()
#38 0x000000000065a5c1 in ?? ()
#39 0x0000000000661ed5 in ?? ()
#40 0x000000000058585a in ?? ()
#41 0x000000000059dbd1 in ?? ()
#42 0x000000000049acb1 in ?? ()
#43 0x00007fe3656e5a15 in __libc_start_main () from /lib64/libc.so.6
#44 0x000000000049d2b1 in _start ()

Reported using DrKonqi
Comment 1 Harald Sitter 2013-07-03 23:19:30 UTC
Gstreamer bug, please report upstream.
Comment 2 Jekyll Wu 2013-08-05 15:17:19 UTC
*** Bug 323194 has been marked as a duplicate of this bug. ***