Bug 321598 - cmake doens't check for qtwebkit
Summary: cmake doens't check for qtwebkit
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.7-git
Platform: Other Linux
: NOR normal (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-25 13:43 UTC by Harald Sitter
Modified: 2013-06-28 07:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Sitter 2013-06-25 13:43:46 UTC
amarok links against qtwebkit but cmake doesn't actually check for it during configuration state, so the cmake summary says everything is fine and then build fails because headers are not found.



Reproducible: Always
Comment 1 Mark Kretschmann 2013-06-28 06:53:02 UTC
Hasn't QtWebKit been an implicit dependency of Qt? I'm asking because noone has complained before.
Comment 2 Harald Sitter 2013-06-28 07:00:12 UTC
You can compile without qtwebkit. More to the point though on a distribution package level you mostly everywhere can install qtcore/gui without dragging in qtwebkit because there is no dependency there.
Comment 3 Mark Kretschmann 2013-06-28 07:49:54 UTC
Git commit 8553ca7203718eb90ccfeeb8a79d9d33abe27c35 by Mark Kretschmann.
Committed on 28/06/2013 at 07:46.
Pushed by markey into branch 'master'.

Add missing CMake check for QtWebKit.

I've also added checks for all the other Qt library components
we depend on. Please check if I have forgotten any.
FIXED-IN: 2.8

M  +3    -3    CMakeLists.txt
M  +1    -0    ChangeLog

http://commits.kde.org/amarok/8553ca7203718eb90ccfeeb8a79d9d33abe27c35